What USB noise isolator is recommended

I was waiting for a USB isolator to be sent to me from Langmuir. I’m tired of waiting on them. What brand and where did you get it. I don’t care the cost , I just want the damn THC to work. I’ve narrowed it down to that with the flow chart. I tried a cheap one from Amazon but it wouldn’t even let the machine run a program. Thanks’

I use this one with a CNC mill more as an extender than noise reduction, much less RF noise from the mill than plasma though:

I also put ferrite beads on all the cables, at the computer end and at the Langmuir interface box:

I use the Ferrite Core Choke Rings myself with great success. Do not put any on the torch voltage wiring to the THC though, it don’t like it at all!

i wouldn’t recommend a USB extension. i try that exact one when the original crossfire with mach3 and it would cause all sorts of interference problems. if you’re going to extent the cable just use a long good quality one.

what problems are you having that you think you need an isolator? you only have 2 posts on this forum since you joined so if you’ve been having problems, you haven’t posted anything for help.

2 Likes

@JChriscoe please do not take this the wrong way…but @nicaDd has got a bit of a point…

We would love to help but one Isolator is really not much different from the next…how long have you been waiting ?

I thought I needed one…but nope…turns out it was crossed wires and ferrite chokes solved that issue.

Maybe if you tell us some of your problems we can help in other directions.

what plasma unit are you using?
what are your symptoms?

Fill me in on these Ferrite chokes…. Sounds like something to make someone’s day easier down the road. Assuming they help with RFI? New guy trying to get all the right stuff from the get go….

I’ve had my machine over a year, I’ve gone through the flow chart from Langmuir. I have ohm tested The Vim box, tested to make sure the electronics box was not grounded to the table, swapped usb cables. Ect. Here’s the thing, THC worked with my laptop. With the new software update my laptop would not run fire control at all. So I took my very pricy desktop out to my shop to cut parts and it worked perfectly. I got sick of the laptop issues, so I built another desktop to run the table. Everything works in fire control now except THC. Langmuir has been good about helping thus far, aim just getting impatient. According to the flow chart, I’m getting voltage out of the cutter using raw voltage. Tried divided voltage also. Good both ways. Voltage is good going into and out of VIM box. Voltage going into table and into the THC circuit board. I cannot for the life of me get any voltage to show up in fire control. I did have it show low voltage for a very short time in fire control, then it randomly quit. I am having to use a usb extension, but even if I take it out and put the desktop right beside the control box it makes no difference. I’m using the same USB as I was with my expensive desktop. I have tried different USB cables, different brands and ferrite chokes. I have ran into a bunch of technical issues trying to get this all setup. When I get one figured out it seems like another comes up. No mechanical issues at all. I love the machine when it works as it should.

I replied to the other guy, it’s kind of a long reply so if you don’t mind, read it there. To add more info, I have a desktop in my home office that will run the program perfectly with no issues. With the dedicated pc I built for the table I cannot get THC to show voltage in fire control. Raw or divided voltage makes no difference, also changed VIM boxes.





If you want to get serious with dealing with EMI
This is how hypertherm deals with it.

And run your computer off on UPS (uninterrupted power supply)

The way I see it the Ferrite squishes or “chokes” the magnetic field around the wire turning any stray electrons (noise) into heat ( not a perceivable amount)

*The last paragraph in the series of screenshots above also talks about ferrite chokes too

What kind of Plasma are you running?

Are you hooking of your THC leads internally or externally (cpc port) to that machine?

did you ever try switching the polarity?

When you did ran your laptop did you run any other peripherals at the same time?

Hell, Ill give it a try.

Cut 60 plasma. thru the CNC port on the back of the machine. When the laptop was used it was unplugged and it was by itself. Which polarity’s are you asking about? Also to add I used all of the same cabling, that was on my office desktop. I moved it temporarily to make sure everything was gonna work in fire control. It all works perfect with my office desktop, Even reads good voltage in fire control. To clarify I just changed desktops, no longer use the laptop. all peripherals and cables are the same

Does your desktop have a 3 prong plug?

It is notorious for inference issues .

the red and black wires for THC . Work ground is positive on these systems

1 Like

yes it does

Im aware of the interference issues. Had no issue with another desktop.

try running without the ground on the 3 prong plug.

either by cutting it off or using a 3 to 2 prong adaptor

Ill give it a shot

if I am not mistaken Langmuir has stopped supporting the cut 60 due to this issue…hate to say this…but have you considered another plasma cutter just to see if it solves anything?

I have another cutter. My thing is that I had all of this working perfectly with another pc. I cut a lot of parts with no issues. I’m using the 60 because it has the DRO and will cut thicker steel. I’m gonna try everything else first. I know the issues with the 60, but had no issues with a different pc. I’m also doing all of this so maybe it will help someone else in the future