USB recognized but won't connect

you can reload 20.6 if you want

I did. Have both versions on the machine. Now 20.6 doesn’t even find the machine at all :says Corssfirepro COM4() greyed out.

21.1.4 finds the machine but not the THC. I can manually manipulate it with the up/ down commands, but the IHS/ THC part in the software is non-responsive.

I’ve also opened the cover, and re-seated the IHS module and checked the relay block, all is clean. Red lights on the THC flicker when updating the firmware,

I’ve also:

  • deleted the ports (COM 4 and COM5), then reinstalled and updated the drivers
  • rebooted and power cycled the control box and laptop.
  • Confirmed 112500 port bits per sec rate
  • Confirmed all wiring connections, torch fires fine, x,y,z axis all respond
  • Confirmed IHS sensor is clean and free moving
  • Reinstalled firmware 1.2 several times. Looked around for an older version like 1.9, but the links are dead.

So likely it comes down to bunk firmware, as several other users are reporting the same issue on existing installations.

Same issues. There is a gremlin in the works somewhere. I work in enterprise software and it’s clear this is not ready for prime time, ridiculously buggy that makes the hardware investment a total loss.

I’m having exact same issue. Has anyone been able to resolve this?

Which version of fire controller are you using?

Are you using the provided USB connector with no extensions?

Have you tried to wipe and reinstall your USB drivers?

Have you tried using fire control 20.6?

What operating system are you currently running?

Maybe load fire control on a different laptop or computer and try it.

At least you’ll know whether it’s the way your computers configured or if the langmuir electronic enclosures actually having issues.

Did you ever get the issue resolved? I am having the same problem. I decided to update my Microsoft surface to windows 11. Stupid mistake. Fire control 21.1.4 would not load or open programs. So I downloaded the compatibility version. That will open and run programs but now I lost my THC connection. Tried most of the same things you did less taking the machine apart.

Any feedback would be appreciated on if you were able to resolve this.

Which version of fire controller are you using?
10.0.18362.1 by Microsoft

Are you using the provided USB connector with no extensions?
Yes, tested also another cable

Have you tried to wipe and reinstall your USB drivers?
If you mean drivers of “Crossfire CNC” than yes. Makes no sense to reinstall drivers of USB controller itself, as all other peripherials works fine.

Have you tried using fire control 20.6?
Yes, this one shows only “No Connection” and offer newer version

What operating system are you currently running?
Tried both Win10 and WIn11. Windows 11 is with AMD CPU and two laptops with Win10 have Intel

Maybe load fire control on a different laptop or computer and try it.
Tested on 3 computers (2x Win10 and 1x Win11). Same result on all.

What is strange a bit for me that it looks that motherboard of Crossfire is powered only by USB from computer - when I switch on Crossfire Pro, there is no one LED active. When I connect it to computer (even when Crossfire Pro is turned off), yellow LED flash once for short time and green LED turn on.

Another thing where I’m not sure - Do your motors on Crossfire Pro also start hissing when you disconnect the USB from the computer?

this is normal…

1 Like

Sounds like you tried everything.

Well maybe the USB connection on the actual langmuir electronics enclosure is letting power through but not data.

Better go start a service ticket.

Sounds like you did all you could do on your end.

1 Like

We’ve tried all the recommended things stated above and still getting CrossFire() on the Machine’s dropdown connection, as shown above on 1/10/22. Reached out to Support Friday afternoon and have run thru their recommendations with no luck. Tried all versions on listed on the download page.

Anyone else had any success getting back up and running? Thanks in advance for any guidance you’re able to lend.

In fire control you’re NOT getting a green light to highlight that your USB connection has connected from the computer to fire control?


Just so we can start with the definition of your problem.

Thanks for the prompt reply. The green light is illuminated on the controller cabinet around the USB B connector and I get the audible sound that the USB is connected. In FireControl, it does not show the green as you pictured. It shows the USB as connected in the Device Manager as well.

1 Like

Sound like its supplying power but not data.

are you using an usb extention?

are you using the usb cable provided by langmuir?

No extension. I was using the provided cable successfully up until Wednesday of this week. Tried a new shielded cable from Amazon today with the same results. Table hasn’t moved location, so can’t imagine something in cabinet came loose.


Maybe trying a third cable.

Updating your USB drivers.

Trying a different USB port in your computer.

I know you may have tried some of these options already.

And then after this is exhausted that’s when I would be wondering whether the usb port itself is hooked up to the board inside the enclosure.

But let’s get all the external stuff checked off first


Has anything changed on your computer? Updates? You may want to reinstall the driver from the downloads page just to be sure something isn’t amiss.

Have you tried another laptop? Your use case definitely seems like there shouldn’t be an issue with the motion control board as it was just previously working. Getting the same issue on another computer may point to the MCB.

Trying a new laptop resolved the issue. Thanks again @TinWhisperer for all your suggestions. Very much appreciated.
Any guesses as to what to do to resolve on our laptop (non borrowed)?

Thanks in advance.

1 Like

Here’s the link to the Langmuir’s software download page.

You could try uninstalling your current USB drivers(in the device manager), restart windows, and when Windows reboots and starts recognizing devices plugged into USB ports it will automatically want to reinstall them.

On the Langmuir software download page there’s some USB driver download options. What operating system are you using?


Believe I’ve tried all the DL options, with deleting and reinstalling. Running windows 10. Same as the computer that runs.

For some reason your computer does not want to accept another USB profile.

If a Windows update doesn’t work.

If a manual uninstall of the USB drivers doesn’t work.

Then you might be looking at a Windows reinstall.