USB not recognized

Hello. Hoping somebody can help. I was cutting yesterday morning with no issues. I shut down and unplugged the USB. I went back a few hours later and now I get a message that it doesn’t recognize the USB. I did verify that the USB port is working on my machine. I also uninstalled and reinstalled Mach to see if it would recognize the controller. I also verified that I had the controller in the plug ins etc. I do have power to the box. I can hear buzzing.

Suggestions on what else to look at? Appreciate it!

Sounds like the motion control board failed. Let me discuss with @langmuir-mike tomorrow morning. Unless he says it could be something else, we will get a new one sent out.

Hi @schaef1333,

It’s possible there could be an issue with your USB breakout board. Do you have another computer that you could plug your electronics box into to rule out if it’s an issue with your computer? Also, what plasma cutter are you using with the table?


Razorweld 45 is the cutter. Will try a diferent computer tonight. Thanks

Tried a diferent computer and got the same result. Also tried a diferent cord with no change.
Still get usb device not recognized.

Sounds like you’re having a similar issue to me. I was making cuts all morning without a hiccup. Shut everything down, go to lunch, come back and now I get the fault message “RNR Motion controller not found.”

I’ve cycled power, swapped cables, and laptops, and no luck.

Get it fixed?

It sounds like your motion control board failed, please send an email to and they will send a new one to you today via USPS 2 day shipping. Sorry for the inconvenience!

Is there a known reason for the failures, and is this new board updated?

I sent an email and got a reply a few min later with shipping confirmation. That is very much appreciated.

The failure mode on the board since inception has held steady at 0.8%. A decent portion of that has been from folks running high frequency plasma cutters. We don’t have a good grasp of the root cause, but we are actually working on a rev 2 of the board (I can’t get into those details unfortunately).

The forum is a great tool for our customers, but also makes issues seem more common than they really are.


Right on.

My plasma cutter is a blow back style or whatever it’s called. I believe that’s what’s suggested to be used with this table.

This is definitely a great forum. I’ve leaned many tricks.

This happened to me at least 6 times today trying to cut 2 different files. The table stopped moving at different points each time it happened. All were close to the beginning of the file. I got a windows dialog " USB device not recognized"

I tried several different ways to get going again, reboot, check cable connections, cycle the control box off and on, close and restart Mach 3, etc. At least couple of times, maybe more, there was a dialog in Mach 3 but I don’t remember what is was.

One other thing, today was the hottest day I’ve used the table. I noticed the control box was relatively warm.

I’m using Windows 10 Core I7 with USB 3 port direct to control box. I also disable auto virus before starting.

I was eventually able to finish both files.

I forgot to add, I’m using an Everlast 50s.

One more thing… At least 2 possibly 3 times the table stopped while the torch was still firing. Torch on/off in Mach 3 would not turn off the plasma, no connection. I had to switch plasma off manually.

Have you put some distance between the cutter & the Crossfire or the laptop & Crossfire?

The plasma and table are 5 to 6 feet apart. The computer and plasma are close. I did check the cables to make they were separated and not running parallel to each other.

This is a new problem. The computer and plasma have been on a roll around cabinet since I first used the table.

Bummer. May be a failing part in the control box. The device separation (as well as adding a chicken to the USB cable) has helped others but their problems seemed to be consistent and not sudden onset.

At one point I even changed the ground from the drain nut to the material being cut.

I had a similar issue with my Table. My Plasma cutter is not Langmuir approved. I did a bunch of work adding Earth grounds to everything and a new grounding rod 5’ away from the table. None of that fixed the issue (I’m sure it didn’t hurt anything). Last thing I tried was getting a high quality USB cable with Ferrite beads on it. (example ) (I’m not affiliated with the sellers of this product and get no kick backs…Just very Happy it worked!)
Less than $10 us fixed my issue.

1 Like

Thanks for your reply. Based on your recommendation I ordered the cable in the link.

Let us know if it works for you. That way when someone else has the issue they can search the forum and see a fix.