Touch screen doesn’t have touch capabilities? (SOLVED with replacement)

Howdy y’all, fairly new here to the forum!

Putting together my Mr-1 and got to the set up portion of the wiring and downloading cut control etc. On the first power up I couldn’t get anything to respond to touch, but the wireless pendant worked so I went through and did all the set up using the pendant.

When I got to the portion of setting up “pen and touch” and feedback I realized that 1 I didn’t have that menu and 2 I noticed in a different menu that my screen “device doesn’t have touch capabilities”

Anyone had this problem? Am I missing something?


Did you plug in the usb cable between the monitor and pc?

1 Like

Affirmative, I’ve hooked everything up as far as I can tell.

The pendant works just fine but zero touch response

He is talking about the one that looks like a printer cable. You should have two. An HDMI for the monitor and a USB cable to run the touch screen functions.
The pendant works on bluetooth.

1 Like

Correct, I have the usb running from the computer to the touch screen, does it matter what port it’s plugged into on the mini pc? Right now it’s plugged in next to the usb isolator like in the video


Try a different port. Try to connect the monitor to a laptop or other pc to eliminate the mini pc from Langmuir.

@ Roadrunnermfg

That was 29 days ago. What happened?

Langmuir sent me a new Touch screen and cables and it fixed the problem!


AHH, important to know. I have a problem but my touchscreen has a no data dialog box come up and valid HDMI notice before the Home Screen turns on. The mini keyboard turns on the login box on the touch screen but does not jog the computer. I cannot enter login info on the touch screen. Unresponsive. I contacted support.


1 Like