Touch probe/ tool setter retraction distance triggers cut control 22.1 bug - SOLVED

Is this a known issue? Is there a list of known cut control 22.1 defects?

There’s a post with requests for fixes and/ or additions. I think this made it in there. I cant open the probe routines menu without using a mouse touch screen wont work for it. Interesting yours makes the move then decides its not going to work. Mine errors out immediately when it’s over Z. Maybe the Z probe routine is different. what happened to your ruby?

I drove the stylus into the toolsetter because the Z axis wouldn’t raise. I thought the axis was stuck, as happens to the other axes, and assuming there was some downward travel left on the toolsetter… I was wrong.

I was frustrated with numerous problems and if I had stopped to think, I probably would have been fine if I disabled the soft limits and tried again. At least the idiot tax was only $50.

The stylus is $50?

If you want a “good one” it is $44 before tax:

@safety3rd You have the spindle in the down position and even with a 0.5" retract it would hit the top limit switch so the soft limits is preventing the movement upwards. That’s why you are experiencing this paticular error. If you are going to be frequently machining in a vise I highly recommend moving to the spindle UP position.

EDIT: the next release of CutControl will allow for a smaller retract distance on the probe.

1 Like