Torch won't fire

Crossfire pro with a hypertherm 45xp. Worked last week cut no issues. Today loaded up a program and some steel and went to cut and the torch didn’t fire. Heard the clicking from the relay and no fire or airflow. Updated all software and retraced all wires everything was as it was when it worked last week. Hypertherm is showing no errors and firecontrol shows torch is on. Tried manual fire and nothing there. Checked the torch on off wire for continuity and that was fine still no fire. Only thing I do when I don’t expect to use it for a couple of days is drain the water table. I turn the electronics off and clean it up other than that no changes. I have the ls hypertherm cable to the torch controls if that makes any difference but check the pins and found everything there looked good to. I’m stumped was hoping you guys could help me out. Thanks!

when you are talking about manual fire is that through Firecontrol ?

are you actually pulling the trigger?

you need to first see if your plasma is working at all by taking it out of the table and using a hand torch to see it it fires up…if not then that is where your problem is…

I have a machine torch so no trigger to pull however I can jump it to get it to fire and it works no problem.

Then its not the plasma cutter. It has to be something in sheetcam, drivers or in the Langmuir controller.

can you hear the relay click inside the control box if you try a manual fire from firecontrol? if you don’t then it maybe came loose from the board.

I don hear it and I spoke with langmuir who sent out a new relay and I’m still not able to get it to work.

does the new relay click?

It does not. I’ve also exhausted the entire troubleshooting page for torch firing on their support page and still nothing.

I’m having the same issue. After about a week of working on the table to get the leaks to stop, firing it up for a job and nothing. I have a manual torch and fired that off and it works fine. THC is operating, checked all wires, etc. Any help is appreciated.


I ended up contacting langmuir and trouble shot with them, it turned out I needed a new motion control board as my original wasn’t working. they were great to work with but it did take a little bit to diagnose the problem. they sent out a new board for free and that solved the problem.

1 Like

How do you know the THC is operating if you can’t fire the torch? That only shows voltage when the torch is firing. The Z axis moving up and down has nothing to do with the THC.

Do you hear the relay click inside the control box when you press the torch fire button in Firecontrol?

What plasma cutter are you using? If it is a Razorweld, try switching the cables on the front of the plasma cutter.


Thanks. I’ve gone through their steps and waiting response.

The relay doesn’t click. It was operating a week ago, then stopped.

Sounds like the relay is bad or is not fully seated on the board. Check that the relay is fully seated on the board.

1 Like