Torch will not fire on command of Mach 3

Hi David I’m working on getting my plasma cutter all hooked up and I’m ready to fire it through Mach 3 it will not fire it will fire with my finger on the trigger but when I hit the button on mach3 it does nothing I’m confident that I have the correct two wires hooked up to the cable it was the small nodes on the top is the two that I found that did what it was supposed to do I have took the connectors back off and made sure that they cut through the cable and they were touching the wire also made sure that the Spades are touching where they’re supposed to touch I still get nothing

Do you have the motion control plugin and the crossfire configuration installed?

Have you checked that you get continuity on the male end of the torch fire cable when you squeeze the trigger?

Oh s*** I forgot all about that thank you for getting back so quick that was my fault I got to go to the downloads page and get that forgot all about it

I believe I already have that downloaded I have already run the break-in software and got that completed I would not have been able to do that if I didn’t have that downloaded would I?

Yes I have both of them installed

@jeremybillenstein Hi Jeremy. We’re sorry to hear that you’re having torch firing issues but hopefully we can troubleshoot a few things here.

In order to check if your plasma torch wires were correctly spliced, you will need a multi-meter to check for continuity. With the torch wiring unplugged from the CrossFire electronics box, pull the trigger on your torch and place one of the multimeter probes on the outside of the barrel connector and one on the inside. You should have continuity when you pull the trigger and no continuity when released.

If you have continuity here, we need to check to make sure that the relay in the electronics is firing properly. Open up Mach3 with the CrossFire V1.1 profile and unplug your torch cable from the box. Next click ‘Torch On/Off’ and you should see a yellow light flashing on the screen. Use your multimeter on the torch on/off female jack and place one probe on the pin connector and one on the inner diameter of the barrel connector. There should be continuity here when the torch is firing from the computer i.e. the torch On button is flashing yellow. If you still do not have continuity here it is likely that your settings in Mach3 are incorrect. If this is the case, you please post a screenshot of your Spindle Setup screen (Config>Ports and Pins > Spindle Setup) as well as your Output Signals screen (Config >Ports and Pins> Output Signals) in Mach3. Please also post a screenshot of your General Config settings.

If we check and all your settings are correct then likely your relay is bad and we would need to send out a new wiring harness with the integrated relay. Rest assured we will get to the bottom of this issue and get you squared away ASAP!

1 Like

1 Like

Hi, Can you also take screenshot of the output signals screen by clicking on Config—> Ports and Pins—>Output Signals?

1 Like

Thanks, that all looks good which means that the issue is unrelated to Mach3 settings. That means that either the plasma cutter wiring is incorrect, or the relay inside the CrossFire electronics box is malfunctioning or that one of the relay wires has been disconnected.

Do you have a digital multi-meter that you can use to perform the tests that @langmuir-mike described?

If you don’t, consider using a piece of wire to short the male end of the torch fire cable (the end that plugs into the CrossFire). Doing this should fire the torch. If it does not fire the torch, it means that the torch fire cable was spliced incorrectly.

If it does fire the torch, then it means that the issue lies inside of the electronics box.

Mike I have verified the torch wireing and it is correct. In regards to the relay should there be power from the circuit board to the relay and if so what voltage should it be… I am showing no voltage but the is around 500ohms resistance.

Disconnect the torch fire cable from the electronics box. Set your multi-meter to measure continuity. Hit F5 in Mach3 (should see a yellow blinking bar above Torch On/Off). Probe the two metallic contacts in the female connector on the electronics box. You should hear the beep noise indicating continuity.

To answer your question, when F5 is pressed, the motion control board applies approximately 5 volts to the control side of the relay. When F5 is toggled again, there should be no voltage.

Yes that is correct when it is toggled there is no voltage

Where are you probing with the multimeter? Can you post a picture?

Testing DC voltage with no voltage back

After speaking with you last night in the last message when we sent you the picture you needed we worked on it another hour or so and we are determined that everything on this end is working properly except the control box we’re not getting any voltage where we should be as far as the jumper wire we can use a jumper wire and the end of the torch fire cable wire controller and make the torch fire as if the box was sending it the signal so we know the cable is installed correctly at this point all we know how to do is ask you to send us another control box if you feel all of the settings in the computer are correct I didn’t move or do anything other than the instructional video showed

Hi Jeremy, sorry i didnt respond last night, your motion control board is definetely defective and that is why the torch is not firing. We will get that sent out to you on Monday morning.

hey that is no problem Daniel I totally understand you have to have sleep also and the fact that I’m in Ohio 3 hours behind does it help matter on your sleep I was in California about 3 months ago if I would have been about 4 hours further south I was going to visit you I was out there for work but anyway I was telling all my friends that I talked to about this business I’m starting and how johnny-on-the-spot you guys are with returning messages and customer service I have nothing to say to you except you’re doing an excellent job you can’t expect to put out this many machines and not have an issue or hiccup here and there I will expect the package come middle of the week and install and get back with you on it thank you for being once again so on the spot because I have a lot of things I’m trying to get done for people before Christmas once again keep up the good work and God bless you


Sorry to piggyback on your feed, but I’m having the same issue. I had everything working until I switched from demo to licensed version of Mach. Now I can not get the torch to fire through Mach. It does fire manually. I checked all of your setting above but still having the issue. Suggestions?