Torch stopped firing

Well im finally playing with the table a bit more and after a half producive day i hit an issue and could use some guidance.

Background info: pro table, with primeweld cut 60 plasma with a ptm60 machine torch. I have the torch fire leads wired to the controller. Im using a combo of bendtech sm and gibbscam for my cad work and sheetcam for cam. I have made a few successful parts, nothing important with and dimensions but mostly just been playing with the software.

So the problem… i Well i drew up a sign and wanted it to come out nice as it is going to be a gift. So i made a simple part and start dialing in my tool in sheetcam for the 16g mild steel and cut 4 or 5 peices and my torch just stopped firing. I can hear it clicking and the air will flow but thats it. I swapped the hand torch back and it cuts fine by hand. Looked at the consumables and that all looked fine.( although i did have some awful cuts when i tried using 30amp sheilded consumables, and was going to ask about that before i had this issue)

I was using fire control 20.4 so i downloaded 20.5 to see if that would help but nothing there. I and using 1.02 thc and will try updating that this week but wanted to see if you guys had any thoughts. Any red flags or things to check first before i open up the torch head or wire up the hand torch to test.

I am fairly new to this but it sounds like the THC is too high. I do not cut any higher than .075" and that was on some 3/16" steel plate. I believe this is what you are saying by 1.02 thc, or is this MM?

Sorry, i didn’t make that very clearm. 1.02 is the software version i am running. The pierce height is .150 and cut height is .062. And both were .035 thou lowere when i had the shielded consumables in

Sorry! I re-read the post and apologize. So I can’t help, sorry!

post the sheetcam tool settings and plasma settings

Sheet cam tool. It seems unlikely for it to be a sheetcam issue though? Going seeing how it stopped working after a few cuts of the same program?

Quite alright, appreciate the attempt :+1:

whats the psi set to on the cutter? i mostly cut 16 gauge on my CUT60 and “knock on wood” haven’t had any issues with it at all unless it was user error. Machine torch from George.

also, are you using the CPC port for torch fire and THC?

90psi into the back at 55 psi set on the machine.
I too bought the ptm60 from George, consumables as well. I have the cpc port for the thc and the torch is wired directly to control box via the two wires on the torch.

set your air to 60 psi on the cutter so when you press on the air only toggle switch, the dial should drop to around 55. I use the .9 tip at around 29 amps for 16 gauge.

I have my torch on/off wired to the CPC port. I never touched the extra wires that came on the torch. that could be the issue.

I will take those apart if i need too to check the connection but they have been functioning as intended for several months now. About 70 pierce’s to be exact lol
I will try bumping up the air a bit. But will that keep the torch from firing ?

it could be similar to the razorweld where if there isn’t enough air pressure flowing then it won’t fire but you said it fires fine with hand torch so i’m guessing it’s how you have the torch fire wires set up.

Hum, well i will have to check my soldering at some point, but its been working fine up till now so it cant be the mechanics of how i have the torch fire wires done. Plus i can still manually fire the torch and get air flow, just no arc?

have you tried swapping the consumables with the hand torch?

No… i did retry the 30amp shielded consumables from George. They had 3 pierces on them. But they gave me so major serrated looking cuts so who knows. I will try swapping consumables with the hand torch

well seems like it’s something to do with the torch somehow since it fire from hand torch so you can rule out the cutter itself.

If you have the Primeweld Cut 60 then you should not use the wires from the torch. It was stated in the sheet that was sent with the torch. Also There is no 30 amp shielded consumables only 40 amp.

1 Like

Well George, looks like air was the problem. I tried again after work. I bumped the input pressure up to 125psi and set the running air pressure to 75psi and sure enough it fired. I kept backing it off till it stopped and at 60 it would fire reliably and at 58psi it would only fire about half the time. At the 55psi i had been running it fired once and then not at all.

Thanks again for the help on the phone today. And thanks heads up on the consumables. Looks like i stuck the 30amp unshielded nozzle in with the sheilded stuff and failed to notice.