Torch Not Firing with THC Turned On

I recently got my Pro all set up and attempted my first cut today, but was unsuccessful at doing so. After several attempts I figured out that it has something to do with the THC, because when I turn it off, the torch works and cuts fine. I noticed the torch height was actually moving and I’m assuming that is from the g-code. My question is, why won’t the torch fire with the THC setting turned on? I have tried the THC test sequence and it can’t get the torch to arc either. Any ideas?

Do you get lost arc voltage alarm? Same issue I have right this second

Please let us know…
What plasma machine you are using?
What post processer program…conFusion360…sheetcam…?

This helps trouble shoot the issues.


Yes, I get the lost arc voltage alarm. I’m using the Razorcut 45A and I used Fursion360 and followed the tutorials online for it.

Hand torch or Machine torch?

Do you have cnc ports or live voltage?

If cnc ports do you have 2 that are 2 pin OR 1 2 pin and 1 4 pin socket?

It’s a hand torch and has the cnc ports with two 2 pin sockets.

Any luck with yours?

Sorry, computer was down and 70+ hr work weeks.

I can cut with it off, tried last weekend needed an emergency part, it was a disaster with no ht control, I hope to start process this weekend to check all THC hardware