Torch Not Firing - Solved

I have an issue with my new Crossfire machine. And cant seem to get any answers from their support. They keep telling me the same thing over and over again. I load a g-code from fireshare that is cut ready for no Z-axis. When I do a dry run the machine goes through the motions. When I try to run it to cut the IHS light on the bottom stays green. No matter what I load to FireControl the IHS button will not turn off. Does anybody know what is going on???

**edit my bad misread the post.

Did you download this using their new fireshare feature of disabling the THC on cut ready files? I wonder if there’s a glitch with it. Have you ever cut successfully with your machine? What about loading your own post processed files?

1 Like

Yes, the THC feature is disabled. I cant even enable it in FireControl. I downloaded a cut-ready file from FireShare specifically for FireControl with no Z-axis. Its the crude little tractor. This is a new machine that I just put together. I have been trying to get it to fire for 5 days with no success. And absolutely no help from Langmuir. I can fire it if I pull the trigger myself and if I short the torch on/off cable. Otherwise FireControl wont fire the torch, even when I press the Manual Torch Fire button in FireControl.

do you hear the relay click inside the control box when you try manual fire in firecontrol? if not, look inside the control box to see if the relay is seated correctly. sometimes during shipping the relay will wiggle out of the socket. all you have to do is pop it back in.


I do not hear a relay. ---- I opened the control and found a relay lodged in by the power supply. Do you know where is goes?



That did it!!! Cant thank you guys enough. The Forum support is the Best.


Actually, IMO, you should change the title of this thread. Because it is seriously wrong.
And cool your jets, because this place has probably the best support you’ll ever get…


I agree with @TomWS ! Sometimes it is best to post a problem on the forum first. And a shout out to @nicaDd for the reference picture…
I think Langmuir has very good support. They don’t use the machines as we do so they aren’t as updated on some problems as the Users of the forum. I have learned a lot just reading the posts.
In the setup instructions it notes that the modules should be checked for proper connection.
The forum is the place to be!!

1 Like

I would state this as, Langmuir has very good support AND they are very busy AND they know that the folks here will help - a lot. So, looking at the total package, you won’t get better than this.

PS: @Dustybunch, You DO know that you can change the thread subject line, right? Just click on that little pencil icon near the title…

Good point, Thanks @TomWS

why am I seeing the little pencil there on someone else’s thread?

Glad you got it working @Dustybunch

because they edited it after they initially posted it.

Like this.


I’m curious what Langmuir told you, you said you couldn’t get an answer and they kept saying the same thing. What was it?

As a new guy, I didn’t order a machine yet…this title really had me thinking twice.

BTW, I pulled the trigger last night on a PRO (searching the threads now for laptop recommendations). As I said in my first post you guys rock on here!


If he had followed the instructions, this probably wouldn’t have happened.

It’s also in the list in the troubleshooting guide


Hey @Sacco check this thread out. It’s the route I’m going and to me it’s a nice setup. I can keep my laptop upstairs and clean but also use the flat screen downstairs for other items (my business related stuff) and it won’t break the bank.


Honestly some of my problems would have been solved by reading the instructions too. My low live voltage issue from having my laptop plugged in is covered on the site and in the forum.

I think that getting this machine set up and going is just information overload for people. I know it was for me. Also, I think we are all the same kind of people, in our workplaces or friend groups we are the fixers or problem solvers so we all think we can just jump right in to stuff and figure it out.

Yeah I’m waxing philosophical, but Lately I’m trying to remember my own struggle to get everything set up.


@brownfox I believe you’re on to something. I know I’m the type that opens the box spreads the parts out and start bolting them together. Instructions?!?!? You mean the paper I used to start the fire? Whoops. I’ve tried to always get on the forums and search the issues I’m having (even not cnc related). I believe that in most cases I’m not the only one having these issues and hopefully can find a solution online somewhere. I hate the choice of wording he used on the title because it is a red flag right from the start. Glad he figured out the issue and hopefully can start cutting parts out

1 Like

Aside from that, I think alot of people buying these tables think it’s as simple as plugging everything in and hitting GO. for instance, I believe the OP went straight into it and downloaded a “cut ready” file thinking it’s going to magically all work seamlessly and as soon as they realize it doesn’t, they get upset at the company for the machine not working as expected. And I’ve been seeing that alot more here and in FB.

These machine aren’t plug and play to say the least. Not even the more expense set ups are. There are alot of other factors to consider even when trying to to cut your first straight line.

I came into this as a total newbie, not knowing anything about CNC or what it entails but I read and read and read everything i could before i finally purchased the table. then i found out about needing clean dry air so i read some more and went the aftercooler route and other ways of moisture prevention. I’m not saying I’m an expert now but i now have an understanding of how things work and try to help out when i can. And during all that, not once did i complain or blame the company when something didn’t work. i fixed everything myself and gained valuable info in doing that.