Torch not firing, but does manually

I think he means when you press F5 normally does the torch fire. I assumed it didn’t, but that’s a good test as well.

1 Like

Yes it fires when I push the f5 button

Ok that is weird then, if it’s firing when you push F5 then it’s definitely not a wiring issue. Hmmm. It almost seems like telling the torch to fire didn’t make it to post-processing for some reason.

Does anyone have any other ideas?

It will go through the motions and all. Other than it won’t fire automatically. I have video of the cutout. I can get a screenshot of the commands.

Are you running Win10? Did you install the patch for it if you are?

Can you post a screenshot of Mach3 when it’s running the file?

Hi @Markc, I haven’t read the comments below yet, but I’m wondering if you found this thread yet and worked through it? Torch Not Firing - Troubleshooting Guide

1 Like

I haven’t checked with a meter yet, but everything runs and cuts.

I’m running Windows 7

Did you set your 0,0?

The code is correct - it’s moving, turning on the torch (M3) and pausing. The profile (Crossfire) is correct too (something often missed).

However the position coordinates it’s showing are negative. Do you have something other than lower left set as your reference?

Would that effect the machine not wanting to fire though? I saw the coordinates, but didn’t notice it before. Thanks

Not sure if it would. But the rest of your setup looks fine and it’s wired correctly or the F5 test wouldn’t have worked. You’ve got the cutter set to 2T and the Mach3 install has the Crossfire profile and because you’re Win7, it doesn’t need to Win10 patch. Since the coordinates are odd, fixing that takes one more thing out of the running for the cause (or will fix it). To test that, just tell Mach3 to start from that line - it should fire the torch and then pause for the pierce.

This is so weird, I haven’t posted because I can’t offer anything. The problem is either in mach or the G Code is my guess since F5 works, but who the heck knows?

Hello, I am running into this same problem. Here are the details:

  • Windows 10 laptop with patch installed
  • Everlast 50s
  • F5 test works
  • Can correctly see M3 and M5 codes in Gcode but it isn’t firing.
  • Restarted program, relaunched, etc.
  • Origin set and zeroed out (0.0000)
  • 2T enabled

@Markc Did you ever figure it out?

Does it fire for you if you hit F5 in Mach3?

He said it works when he uses F5.

@jamesdhatch Yes, as mentioned it works perfectly when hitting F5.

I also tried manually starting at the first line of code with an M3 to see if that would work and it did not.

That’s good because the torch physical wiring is correct then.

The M03 should trigger it too though. In Mach if you’re on the main screen and press Alt+7 you’re in the diagnostics screen. Click on the Spindle Toggle button (halfway down the screen) and see if the torch fires. Then in the command window try it by typing the M3.

If those all work, then there’s something up with your tap file. You’ll need to post it up here so one of us can look at it and see what’s up with the code that you’ve generated out of your post processor step.

Thanks for the tips. I finally gave up and dusted off my old Windows 7 laptop to try that. Thankfully the same files worked perfectly on the other laptop. Definitely off but I’m just happy it works!

I had installed the Windows 10 patches well.

That points to the Mach3 install being different. Worth checking to see what happens if you reinstalled in the Win10 laptop and tried again using the same steps (plus the Win10 patch) you followed with the Win7 laptop.