Torch Fire relay malfunction

So new pro owner, want to preface this a little bit.

LS customer service replied to my initial email inside of 10 minutes and had shipping information inside of 12hrs for the replacement board and relay.

The problem -

Got everything wired up and ran the break in with no torch connected. I had checked the fire relay prior to this and it was functioning properly. Even did a dry run and the relay worked perfectly.

I installed the torch, got everything routed and wired, and went to cut my first part and the torch wasn’t firing.

Checked connections, still no arc, gave the fire control cable a half twist to make sure it was seated in the socket and the torch fired without command.

Now, the relay clicks as soon as power is connected. I have checked everything and cannot resolve the problem. The relay functions correctly in a bench test, but once installed on the board, engages as soon as power is connected.

Again LS is in the process of sending me a new board and relay, just curious to know if anyone else has experienced this issue.


Oddly enough, yes. Another member had the same type issue. Relay was working, sending the torch fire signal out, but the relay socket on the board had a failure of the contacts to the board.

Do you have THC installed? Does the issue persist if you manually disable it in the THC control panel?

When the torch activates on its own, are you able to turn it off via the Manual Torch Fire feature in FireControl? Or do you have no control over the torch using this feature?

I’ve attached a PDF document with some troubleshooting tests for instances where the torch stays on at all times and cannot be toggled off using FireControl:

Torch Stays On.pdf (456.1 KB)

New board is arriving today, requested access to the Google doc, no THC installed at this time. And the relay was going live once power was connected and not responding to or registering in fire control

@OCMworks sorry about that, I meant to attach the .pdf itself, not the drive link. It should be downloadable now.

Board and relay replaced, also had some peek laying around so made some isolation washers to fully isolate the board from the housing. Everything seems to be functioning as advertised.