Torch doesn't turn off using Straight Cut - SOLVED

Hello, total newb here. I’m using Straight Cut feature in Fire Control. Have THC and am using an Everlasting Power Plasma 60s connected through CNC port. I’ve tried to do a few straight cuts and the torch does not turn off at the end of the cut. Any tips? Thanks

Hi @Ranchero7 when the torch stays on, are you seeing the torch indicator light in FireControl (in the bottom status bar) also stay lit? Also just to make sure do you have your ferrite choke installed onto the USB cable that we provided (at the electronics enclosure side).

Can you generate a straight cut program like the one you had issues with and scroll down through the code to the bottom and then take a screenshot of the code and post it here?


Hi Mike,

Ok, I ran another straight cut. Torch indicator light does go off at the end while the torch is still firing. Here is the GCODE. I also ran another program (the leg shelf brackets) that G-gode had M30 at the end as well. I’ll post a pic of that cut separately as I would like to get some feedback on why it didn’t turn out well.

With the plasma cutter off, do you hear the relay in the electronics enclosure make an audible click on both the start and end of the straight cut?

When I run it without the cutter on I get a message “arc voltage lost during cutting program” and then it stops.

Also - I do have the ferrite choke installed.

Ah I should have specified- you will need to disable (using the toggle button in FireControl) or disconnect (using the Height Controller connection X in FireControl) the THC Controller otherwise it will see 0V and throw an Arc Voltage Lost error as it starts to cut.

This may be something to do with how your plasma cutter is wired. Can you explain how you’ve got it set up?

1 Like

OK - I believe that I can hear the relay going on and off. There is a clear click turning on, but the off one is somewhat masked by the carriage movement shutting off at the same time that the relay clicks.

I have my cutter trigger wired in through the CNC port, using pins 1 and 2 for firing, and 6 for the black + wire and 4 for the red - wire for the THC. Using standard IPT-60 torch

OK. Total Newbie error here. Well, I’ve had my Everlast plasma cutter for about 5 years and have used it a lot, but somehow the switch on the cutter got switched to 4T, which takes another squeeze of the trigger to turn off. Once I switched it to 2T, FireControl could turn it off just fine.


Great thanks for letting us know!