Tool path warning on MAC

I’m following along the tutorial video to create the tool path on my MAC, and everytime I hit ok to create it, it gives me a warning that reads as follow:

Warning: One or more passes were discarded due to linking constraints.

With that error, it will only do the outer pass of the langmuir Architectural Plate, and will not cut the holes…I have no idea what constraints it is talking about…been at it for an hour now…

any ideas?

Check out this thread: Fusion issue with toolpath and contour selection

I checked out the link, I changed the kerf from 0.6 to 0.5 to 0.3 and it’s still the same error…

I assume those are metric values?

More than likely, its not the kerf, but rather the lead in geometry. Try making the lead-ins smaller so that they fit into the holes.

sorry forgot a 0 (so 0.05 etc).

I tried lead-ins smaller but same error…

Wow, I totally lucked out…the fix is this: when I select the holes to be cut, the errows goes up, if I click on them then go down, if I do that for every holes, then it accepts them and create the path…

when all else fails, just push and turns all buttons until you get the outcome you want basically LOL…


I believe that is the switch to start inside or outside the holes. what size are the holes?

idk honestly, didn’t check the hole size. It could be due to 360 on MAC or maybe 360 got an update that makes it “care more” and thus it will only accept holes in certain size in certain direcation…no clue on any of it, I’m a total rookie far as the CAM portion and CNC cuting (but my 3D printing experience already helped me!).

I am new to this myself but if the hole is small the CAM software wont let you start from the inside of the hole. but from the outside no issues but will leave a nib cut in the part.

I understand.

Now to go further into more conundrum, I’m building a shop sign, and depending on the selection order of which letter I select to cut first, it will generate the same error. It won’t generate it if I change the order…this is totally escaping my grasp and super time consuming…not sure why either…it’s specific to the order and almost narrowed it down to be error free only in one specific selection order…drives me crazy!

If you send the cad file to me, i can take a look at it. Please send it to

I just sent you the files, thanks for your help!

By the way, do I need to have the laptop plugged into the table and it powered on for Mach3 to generate the tool path in the table display window?? maybe that’s the issue…I know it’s silly but with the 3D printing software I don’t need to be plugged to the printer in order to generate the tool path…hence I assumed I didn’t have to either for this…

Yes, in order to simulate the program in Mach 3, the USB cable has to be plugged in. The power switch does not need to be turned on.

Ok, well I tried that and no dice with my model, but I ran the Architectural bracket (dry run, just motion no cutting) and it worked great…Now, my model has over 2200 lines of g code…would that be the reason it is giving me issue since we are limited to 500 (?) lines in the demo version?

The USB cable does not need to be plugged in for any Fusion 360 functions to work properly.

If you import a program into trial Mach 3 that is longer than 500 lines, It will only exexute up to line 500 and then stop. It will ignore lines 500+.

ok yeah I think because it only shows 500 lines I have to zoom on it enough to see that portion.

I am having the exact same error issue with the Langmuir world map, when I run the tool path, gives me the same exceptions for some of the islands, clicking the arrows seems to help…the holes for the fasteners also had to have their arrows changed…not sure I understand why Fusion360 is doing that

Ok so if I remove the “lead in” completely (click it off) then it doesn’t give me the issue on the world map design. I tried changing the lead in from 0.06 to 0.03 and 0.01 it would still trigger the error unless I changed the path on the bolt holes from inner to outer.
Far as my logo I started again and it seems to work fine now, so who knows…maybe I was dealing with a design that got corrupted.
I created something else today, which has 0.188 holes and if the lead in feature is on, same thing, I tried all three numbers above (0.06 - 0.01) and no dice either, I either change the direction for the holes or click off lead in to resolve it…not sure I understand, kerf is set at 0.005

After doing a couple cuts and for the sake of bringing closure to this thread (big pet peeve of mine on forums), I finally realized which settings do what, and I was able to completely fix the issue. I misunderstood “lead in distance”, which is what was causing the issue (as Daniel pointed it out to me early on). I also realized after a few cups of coffee (pun intended) that the green line in the path means torch on… the light came on (physically and literally speaking here?? lol).

1 Like