THC nor IHC working

New table for no reason none of my torch height controls working shows green at top of fire control and THC test show good. the first program i drew in fusion after assembling table it worked tried today and it doesnt. the first program the height didnt either wich leads me to believe it isnt the program. the table hasnt been used between times. anyone have a lead for me to start troubleshooting


Hey Zach !!! First rule of troubleshooting----> Start with the easy stuff first.

I’d begin with checking all of your cabling from end to end…

In the mean time, maybe you can tell us a little more about your table and what you’re cutting…? Every little bit of information, even if it seems insignificant could contain a clue to your mystery…!!

BTW, can you manually jog the Z axis up and down currently?

1 Like

Has it ever worked?

The THC doesn’t do anything until the torch fires. The IHS system is what probes the work and sets the Z zero that Firecontrol uses to determine the pierce and cut heights.

The IHS system can only work if Firecontrol gets the correct commands from the G-code. Those are generated by setting the pierce and cut heights in your CAM software. No pierce and cut heights in CAM equals no IHS commands.

It could also be a wiring issue with the IHS switch. If the Green IHS light is on at the bottom of the Firecontrol screen, that means the IHS switch is disconnected somewhere.

If you are running this program in “Dry Run” mode there will not be any Z axis movement. Z axis movements are removed from “Dry Run” mode.