THC height, failed cut, I'm losing it

Ok. So I am literally on the second job EVER with this thing and I am losing my mind. Nothing makes sense.
I am trying to cut 12ga sheets. I am using the THC. Cutting height is set at .07, the Razercut 45 is set to 35A. I am using the stock torch. Sometimes it cuts. Sometimes it just decides it doesn’t want to pierce through and actually cut. I just get the error telling me the cutting voltage was lost. My ground clamp is very secure. the head of the torch is clean. I’m going to completely lose it soon if I can’t figure this out. I even tried NOT using the THC and it did the same thing, just took longer.

posting your settings will help out more. Also, looking at the 2nd pic, your torch holder might be a lil high up on the mount and might be bottoming out before the torch reaches the material. loosen the torch holder and place the bottom of the bar clamp on the mount to just above the L in LS.


torch height is to high, and what is your speed?

Secured to the material being cut, correct?

The rest of your cutting parameters would be a good start.

Did you pass your THC test when you initially commissioned your system?

How are you dealing with drying your compressed air?

Is your air keeping up with the cut?
Too much pressure drop or the compressor turning on too late.

Start with lowering that red torch mount, so that you can see both the L and S below the clamp. It is critical, to the operation of the IHS system, that the Z carriage still be able to travel down after the torch touches the metal. It needs to keep driving down, after the torch touches the metal, so that it can unload the IHS switch.

Post your other cutting parameters and someone will help you.

Ok. I lowered the torch mount a bit. Getting to the material with travel to spare was never a problem.

Settings are 35A power, 70ipm, .07 cut height…I based that on the charts I had found, peirce delay of 1 second.

Air is plenty, the Razercut I think is putting it at 60psi roughly as far as I can tell. Drying is a three stage drying system. One is on the compressor itself, then a two stage bead and filter dryer at the plasma itself. The compressor is easily putting out 100psi, and can keep up with the cuts as far as I can tell from the gauge.

And yeas, I have tested the THC system itself through FireControl, and it passes. I waited about 30 minutes after posting this, did some other work. Came back, reran the program…and it worked fine. Thats the way things have been going. Only thing I did was reset the z height. Which I do every time I run it.

Coming from a CNC mill and laser background, this is just not intuitive.

How often do you change out your desiccant?

What is the current condition of your consumables?

Wet air can grenade a set of consumables instantly.

Having a pressure gauge at your plasma equipment that you can watch will give you the best information.
The one at the compressor could show a totally different number depending on the pressure drop of your system.

Are you writing in a nominal voltage or are you using the smart voltage function?

Are you using a USB extension? Is your laptop plugged in during the cut?
Do you have old fluorescent lighting or other types of equipment on the same circuit that could be causing electrical interference?

1 Like

Were do you have your work clamp? On the metal, the table, the slats, were? Your air should be set at 70 psi with the torch cutting.

Work clamp is connected directly to the material.
How would I change the psi of the cutter? It’s supposed to be automatic isn’t it?

Laptop and controller are the only thing on the circuit.
The beads for the dryer are brand new, as in, I put them in right before I ran the cuts. I use them for other things so keeping them dry and such is not a new process.
I can add a guage right after the dryer, see what is reads.
The USB cable is not standard. I use the not cheap shielded cables for all my machines.
The consumables look ok, a little dark from what I assume is this height issue
I am using the smart voltage

When it works, other than needing some tweaking to clean up the cut, it works fantastic.

Razorweld machines like to run at 70-75psi for some reason. You need to open up the machine and crank up the internal regulator. You could crank it all the way up and control the pressure with an external regulator.

Having the laptop charger plugged in is known to cause voltage issues.

1 Like

Ok, I’ll open it up and do that.
Little frustrating if I have to plug the laptop into another circuit somewhere! Hmmm

@GrainsofSteel I think @ds690 saying don’t have it plugged in at all during the cut.

Or at the very least use a three to two prong adapter. Removing the ground out of the equation.

Could you post the G-Code from your failed cut.

i just came here for similar issue and figured i’d chime in on what i’m chasing. i saw you said you get a msg saying lost or low voltage? i get no voltage and i have continuity between the usb sleeve for printer and the torch gantry. i was able to make one small cut for a demo and was fine and when i moved the table into a better placement after that i lost the ground somewhere on the box and table leg. you may want to check yours- if you get any continuity with your multi meter you have an issue and can email langmuir for the fix. i wanted to reach out here to see if anyone already knows the fix- haha hope you’re up and running. hang int there these tools are badass to have.

Hey mate I had the exact same issue with my plasma cutter and unfortunately its not a software issue. You aren’t doing anything wrong its just that you and I got extremely unlucky and the plasma cutter has a faulty component. I don’t know if you can send it back to langmuir systems and get it replaced under warranty but I decided to get myself a powermax 45 that I can have serviced and repaired locally. I’d have tried warranty but unfortunately shipping costs are too high between Australia and America.