THC has dissapeared

I have been using my pro for a week and have cut many different things with THC working great in smart voltage.Today went to cut out a project and noticed no THC cant even turn it on in upper right corner or turn IHS on ,buttons are not active.tried the cut by manually setting torch height and torch will not fire.Its an Everlast 62i wired for raw voltage. Any chance that plug in chip is defective? first cut was Christmas eve so its a new table. Thanks for any help here,Nick

I find sometimes on my pro it won’t register the THC and I have to unplug and plug the USB in a couple times and then it’ll light up? I’m going to buy a new USB cable before I get too excited with mine.

1 Like

Update - took module out and put back in ,pushed reset on module while box was on. got my THC back. Now torch still will not fire

Does the torch not fire while running the program or does it not fire when you just try to manually fire it through fire control?

been trying and will not fire

I guess the next step would be to see if the signals actually getting to your machine to turn it on.

You could detach the wires from your plasma cutter that controls the trigger , put a ohm meter on the end of it and then try to fire through fire control and see if you get any continuity.

If you do get continuity then it’s either hooked up wrong on the CPC port of your everlast.


Your plasma cutter is not on or not switch to the right settings


Your plasma cutter is faulty.

If you do not get continuity then it’s time to start checking the langmuir side of it.

(And it should be pretty obvious but any electrical testing is at your own risk)


Thanks for staying with me on this problem. tried everything until I found issue. problem was had the gray end cap on too tight ,backed it off some and its back to normal ,cut out 2 Harley wall hangers with no issues. I had read here before table arrived someone else here had to back the cap off some to get it to fire.


I bought this 16 foot cable on Amazon. It works flawlessly. Currently selling for less than $12. I specifically bought it because one of the reviewers stated he was using it with his “Langmuir” plasma cutter table. I have used it for the last 10 months or longer.

1 Like

It sure puts a smile on your face when you get it working again. Doesn’t it?!

yes it does ,just cut these for a few friends ,working perfect on 14 gauge


If you had to back cap off on the torch, then the air pressure to torch is set to low or the plunger is sticking in torch. 110-120 air supply to rear of plasma cutter and air supply to torch 70-75 psi.