THC Firmware installed. Now no response from control box - SOLVED

I updated the firmware per instructions. Seems to install successfully. When I plug in FireControl and turn on the box, the software sees the table, but can’t jog the carriage, zero axes, etc. Tried to reinstall update 2x, same issue.

Of course have plugged and unplugged USB, cycled power, restarted laptop…all to no avail.


Does your machine connection sit in this state? Greyed out / not fully white CrossFire text?


If so its likely the CrossFire CNC Control board itself was flashed and not the THC unit one of times it was updated. If you are getting this, shoot us an email to support and we’ll send the instructions to fix!

1 Like

Yep. That’s exactly what it looks like. Email sent

I had my machine running fine with the THC update 1.05 , except I did not have the torch ready yet. I flashed the new update 1.08 and now I have the same problem as ranchero7 does. I can see the firmware loading I did it 10 times and still they same no change. I went back and flashed 1,05 and no change. HELP!

Did you get any help yet.

If you have the same issue, you likely flashed the Motion Control Board instead of the THC chip. Please shoot us a support email and we’ll get you set up with instructions on how to flash the MCB.

having the same issue. Email sent.

I am having the above issue (my THC is connected and the Machine shows connected but is greyed out), is someone able to forward the info on how to fix it? I emailed Langmuir and I get a “Have you followed the connection troubleshooting guide” response.


have you tried the trouble shooting guide?

close firecontrol and disconnect control box from computer, download the thc drivers from website, install drivers, reboot computer, reconnect control box, open firecontrol. should show up as green now.