THC driver/communication issue (SOLVED)

Just assembled my new crossfire pro, everything works fine except the THC, power light on the board is lit but no communication in the firecontrol software. At first I thought it was a driver issue because I got an error when I tried manually installing it. Now i’m thinking the driver was always fine and maybe its an issue with the THC board itself. I get a usb device not recognized when I plug in the table to my computer and no communication for the THC in the firecontrol.

Initial error that made me think driver

Eventually I thought maybe this meant the driver was fine

My understanding is that the THC should show up under Ports, instead it appears to be the unrecognized usb device at the bottom

Make sure this module is installed firmly and correctly.

In the installation guide it goes through it a little bit.

1 Like

try manually installing it without the control box being connected tot he computer. that usually works.

then restart and connect control box.

Fixed. I double checked that it was fully seated and it seemed to be, but I removed and reinstalled the THC board anyway and now it works.

1 Like

I also hit the button in the middle of the board, don’t know what that does.