THC does not fire the torch

I’ve been over all the threads, tested everything voltages everywhere, cleaned the z assembly, and for the life of me, I can get no consistency out of this setup. It has been working flawlessly up until this point (yes, the THC and Razor cut 45 were working at one point).

I’m using the Razor Cut 45 and the THC. I’m running V21.1.2 of the firecontrol software. The plasma torch fires just fine if I walk up and pull the trigger on it, but the Resting THC voltage always comes back with 0.0v and the subsequent test firings do not fire.

My frustration with this entire rig is approaching my limit.

Any suggestions greatly appreciated.

Make sure the ports aren’t swapped on the RW, some were.

Ahh - sorry - I wasn’t clear enough in the original post. This has worked in the past. Just tonight, as I’m under pressure, nothing.

Rechecking the voltage across the pins on the cnc port, I’m seeing nothing.

Is this a call to Razorweld for further frustration? @langmuirsystems any suggestions?

In case this helps ANYONE - I twisted the plug for in the port marked “torch on/off” and it works now.

For how long? No idea.

Get a new torch firing wire. I broke mine by stepping on the wire and ripping the connector off. Yours must have a broken wire near the connector.

This is the one I replaced mine with:

Just cut off the female end and splice the wires into your torch on/off connector for the plasma cutter.

1 Like

I’m still concerned that during a test, straight line cut, there was no detected voltage across the CNC port on this plasma cutter. /shrug

I just started seeing something like this today. The THC has been working perfectly up until today; it worked fine, in fact, for a couple cuts and then started acting up. It would fire for a brief moment and then cut out. Doing a health test showed 0V, but when I trigger the torch directly through the software and perform straight cuts (using the jog feature) I get a correct live voltage readout.

Can you post the Output text file of your THC test?
You are getting 0V when firing in the test then correct live voltage (80-120V) when cutting?

Wow, thank you for the quick response!

That is correct. It fired the torch during the test but said that it was seeing 0.0V and sent me to THC troubleshooting, but during cutting I did see live voltage (though I believe it was 33-34V while doing straight cuts with jog).

It’s worked fine previously so I sincerely doubt anything is miswired. I’m running an Everlast 52i.

The torch would fire on GO and then immediately go out, whereupon I would get an error about the torch moving without voltage being sensed.

Weirdly, I just went back out to the shop to re-test and everything worked fine this time. Is it possible that a splash from the water table may have caused poor voltage readings?

Thanks so much!

------ THC health check report 11/11/2021 ------


[17:31:20] average voltage = 0.00V


[17:31:39] average values: [71.00V] [71.95V] [73.33V]

I’ve tested the wire for continuity and it checks out OK (I taped the testers to the torch firing wire). I manipulated the wire over and over and around and around (and pretty aggressively) and I couldn’t simulate the short (if indeed that’s what the problem is).

Something in this rig is hairbrained - it works, works well, then poof - stops working.

Could bad consumables (ie: maybe I’m running them too long) be the culprit?

@langmuirsystems do you sell the torch fire cables?

If it’s reasonably priced, can I just buy a new one?

Definitely. Reach out to our support team!