Solved! Sticky plunger: Everlast 82i wont fire

I’m at a loss here. I"ve looked around using the search feature and trouble shot what I could.

Everlast 82i CNC with machine torch (ipt-80m)
XR table

Torch wont fire at all (with or without thc on)
Wired to raw voltage directly to lugs inside machine. Black to torch and red to ground.

Testing: At first, when I checked the voltage at the banana connectors I was only getting 4 volts. After removing and checking both the CNC port wiring for the torch on/off and removing the connector on the control box just to make sure I inserted everything correctly, I started getting 340 volts which is way too high as I understand. I didn’t change any wiring, just reinserted those connectors. However, torch still no fire. The air solenoid is actuating and i have air flow but no arc. I’m at a loss. I’m also noticing that on the cutter itself, when it “fires”, that the display amperages drops from 55 to 23 and then after about a second pops back up to 55. Not sure if this is typical for everlast machines as this is my first time with it.

I have the cutter set at 55 amps and 65psi for air just for initial firing. Also removed and reinstalled consumables just to double check that since this torch and cutter are brand new and I’m not familiar with either one.

Any help is much much appreciated.

Sounds like you have a air supply problem. It should maybe drop 5 psi it will never pilot arc at that air pressure.

65 psi not enough for pilot arc? The displayed amperage is what is dropping on the machine. Not the air pressure.

Sorry, I must have misread what you were saying. Pilot arc is some were around 20 amps so that would be about right. Air to the plasma cutter should be 90 to 120 psi with a 3/8" air line. Set the air on the plasma cutter with air flowing at 70 psi and try that. If your setting the amps at 55 then you should be using a 60 amp/1.1mm cutting tip.

1 Like

I misread constantly. Its either age, adhd, or too much I’m trying to keep track of. Haven’t quite figured it out yet for myself but I certainly don’t judge when it happens to others. After reading your post I went out to quadruple check everything and found that the “springish” part of the torch wasn’t springing. So i pulled out on it and it came out some. Then it started to begrudgingly spring back and forth. Re inserted consumables and got my first fire and live voltage is reading 139v so seems we’re off to atleast the special races. It wouldn’t fire again as part of the same cut file but i did reset the program and it made the initial cut again. literally no dross except for the initial pierce. Definately on the right track. Your comment about air made me recheck everything and led me to gain progress. I appreciate that. I will up the air pressure and go again tomorrow.

1 Like

Also, it makes sense to me now that the amperage would drop for the pilot arc. Thank you for pointing that out.

If you still are having trouble contact me I will be happy to help you with it.


Haivng issues with the torch not re-firing. Doing test cuts just to get the system working. As of right now, to start, i have machine set at 55amps, 75psi at idle, and the 1.3mm nozzle which is what came in the torch. I know that i should be using a smaller nozzle for the amperage i’m using but this is all for initial testing purposes. Here’s what going on. Torch will fire and cut first lilne of line test. However, while post flow is still going, torch will not re-ignite on subsequent lines. If i wait for post flow to stop, sometimes it fires and sometimes it doesnt. I do feel like the torch internals are not “springing” right but i have no prior experience with the ipt torch.

cutter is set on cnc mode and tip saver mode
1.3mm nozzle
75psi @ idle
.5 pierce delay
.15 pierce height
.06 cut height
60gal 5hp quincy set at 110psi before cutting regulator

Any thoughts?

Try 1 second pierce delay. If that works then start going down a 10th at a time till it won’t fire then go up to were it did fire. Also make sure the work clamp is on the metal being cut, not the table or slates.

A 1 second delay helped and it did make the additional cuts. However, i can see the machine moving just before the torch fires and this is causing staggered starts on an other wise straight file. Its as if its needs an even longer delay or like it is getting the fire signal late. Thats my interpretation as the observer anyway. Its kinda seems that the relay is slow to actuate the air solenoid or something as it takes a bit of time for the post flow to stop before the next pilot arc. On both my 45xp and the RW, the torch fired extremely quickly between stops and starts. Is that just the nature of the beast for everlast? Thank you mechanic for your help.

It may also be a program matter causing it. I can’t help you with that. But the Everlast is a little slow firing then some other plasma cutters. Is the Everlast a newer unit or a older one?

1 Like

I am digging back through fusion to see if I am missing anything. They have changed quite a bit since we’ve been waiting on the XR. The plasma cutter itself is a new 82i cnc package. Got it 2 months ago.

As far as I know Everlast has not had any trouble with a lazy air solenoid on the newer 82i.

I’m thinking its somewhere in the programming for now. If I do the test through firecontrol, the torch response is fairly quick, firing much faster than what my file demands. Not as quick as previous cutters but quicker than what I am getting on the table when running a file. Since fusion has changed its post processing appearance I need to go back through it with a fine tooth comb to make sure I have everything set right. Thank you mechanic for your guidance.

1 Like

Question about the plunger of the ptm-80. Is it supposed to have spring back? When i push the electrode in, it stays in. I have to pull the plunger back out by hand. It did have the slightest springyness when I first messed with it but never sprung its full travel if that makes sense. Now its force in and force out. This normal?

Following my previous post. I believe my issue lies with the machine torch. The plunger or piston is not moving freely in my opinion. I can replace all the consumables and the torch will fire manually. Try to fire again and nothing. I have to pull the cup and nozzle back off, pull out on the plunger, and then reinstall everything. It will fire again for the first time but not a second. Even if i actuate air first and not initiate an arc, it wont fire again until i pull the plunger back out. I have blown it out with air, sprayed wd40 (all i have at the moment)on the piston, blown it out again thoroughly. Plunger still seems tight and will only fire the first time. Doesn’t want to fire again even after post flow like i was getting before. These late nights sure never seem to stop.

try again without the tip saver function turned on.

take apart the consumable pack again take a really good look at your swirl ring.

I would double check in the manual that you’re consumable pack it’s all compatible with that machine torch.


If the plunger is sticking it will not fire a lot of the time.

I would contact Everlast about the torch.

Things that cause the plunger to stick on the 80 amp machine torch.

Torch holder clamped on the torch head (black part) you never clamp on that, only clamp on the barrel.

Water and/or dirty air.

Doss getting up inside from blowback (piercing)

You could try this, do not use spry lubes or oil.


Heres what I found. Inside the clam shell just above the consumables pack, one of the safety wires(blue) appeared to have been wedge between the plunger and the “centering” pin (plastic tab) that the plunger centers itself on. Noticeable pinch marks on the blue wire. As soon as I released the clam shell, the plunger sprung out. Reorganized the wires and shes springy sprunging again and firing like it should. Thanks everyone for the help on trouble shooting.

1 Like

Hmmm… Sounds a bit like “AvE speak”…

Yup… Definitely “AvE speak”… !!!

Fellas… We’ve got another one!! Seems there’s more and more of us every day!! LOL :crazy_face: :crazy_face: :crazy_face: