[SOLVED] Help, no torch control

Morning guys, i have a Hypertherm 65 sync that will not fire anymore when in manual mode or anything. can anyone tell me what voltage I should have coming out of the (torch on/off) outlet on the langmuir control box? The red light inside comes on when i click (torch fire) but nothing is happening!

  • hypertherm is on and air is supplied
  • no fault codes on anything (langmuir or hypertherm)
  • all other plugs are ran correctly to the VIM
  • ground is on work piece on table
  • fire control version 21.1.5 is up to date

*** this happened after trying to run a sample test for the very first time, i hit start, torch came down to touch off, came back up, then nothing other than an error code stating (toch did not fire or sense any voltage)

any help would be great so i can try and get this bad boy running!

In picture on your other thread. No air line on plasma. Is it possible air not hooked up?

morning Phillipw, those pictures were taken as i was walking out of my shop for the night so everything was shut down and cleaned up. air was applied during the trial. I do appreciate the input though!

Got ya . Do you have a hand torch for plasma? If so will it fire with it?

Wish i did but not at this moment.

i just tested the torch manually and it fired by jumping the connector on the back of the hypertherm unit so something on the fire control / langmuir side isnt working

Not sure I am not around my table. I am thinking maybe the torch on just closes the circuit. Shouldn’t have voltage. If I am thinking correct.

correct, all you are doing is closing an open circuit.

Have you checked to see if circuit closing on torch on cable?

Do you hear relay click?

i do not hear and clicking of a relay coming from the langmuir control box which would make sense on why the circuit is not closing to fire the torch

I think the can come loose take cover off check it.

Can? are you referring to the relay?

Yep do a quick search on here may find pictures and instructions.

okay, great! thank you!

Let me know what you find.

1 Like

So I just got my table hooked up to the 82i and tried to manually fire for the very first time and nothing. I jumped the plug and machine fires. Tested continuity on the pins on a control box when commanding to manually fire and no continuity. I took the control box panel off and all my lights are on including the red one above the surface mount relay on the motion control board. I called Cameron this morning and he’s sending me out a new motion control board. The relay is no longer replaceable, because it’s surface mounted soldered to the board.

1 Like

Oh That’s not cool at all.

I will have to get on the horn! Mine comes on as well and I did notice that there was not a removable/ replaceable relay.

@TMFAB didn’t mean to steer you wrong. I didn’t know about the update.