Razorweld 45 with Machine Torch stopped firing

Hi all I am somewhat new to plasma stuff,

I decided to buy the Razorweld 45 with the CF Pro as my first plasma cutter, and upgrade if I need to, (maybe after I pay off Affirm). I just got the table, had it set up and worked just fine for a few days, (pretty excited too!!!) but trying to get better results with thin stuff.

Now it wont fire.

I tried raising the water level to within a hair over 3/4" from the slats as I read a post that this and running faster than the google sheet helps reduce dross with 1/16. I saw the machine start to fail to make complete cuts. I turned the machine off. I did check the consumables, it looked ok, maybe a little dirty/sooty?, so I brass-brushed them clean and put it back together. Now, it won’t even fire.

Another thing, When searching the forums for how to troubleshoot this I just learned of the 4t and 2t toggle on the cutter. I had been running in 4t (even had a few misfires where the torch kept firing and I had to flip the machine off). Anyway, I cannot dry-fire in either 4t or 2t, but I do hear a click, and air blows. I tried turning everything off and on a few times and the THC test as well as manually firing it.

The forums have been a huge help in getting going, (my welder voltage split was backwards from instructions), but I feel stuck now. What should I try?

If air pressure is too low at torch it won’t fire, no matter what brand. Make sure you reassembled torch correctly.


Oh thanks. I will check, there might be something to that. I had been feeding it in at 100psi but dropped it to 80 (at the compressor) as part of my change Saturday so that I wouldn’t hear the compressor turning on as often.

You wont see much change in changing your pressure on the compressor on how much it runs.
It will always have to run enough to supply the cutter with what it needs.
Do you know HP or CFM out put of your compressor?
When you have a small compressor you can make up for low CFM by increasing the air pressure in the tank to a point.

On you pressure switch set your cut out pressure to 125PSI and cut in 110PSI unless your compressor is undersize then will need to bump both up accordingly.
If you have a regulator on your compressor you have it set to 125 psi min
Normally you would regulate air pressure at the tool it self.

Let us know how you come out

I just tried with my air compressor back up. I misremembered the needle, it i had been set to 120, down to 100, now its at 120 psi again. Tried dry firing with 2t and 4t.

So its good to go?

My air compressor is a 2hp running 6hp max 33 gal - Craftsman I have had a while. I am not sure if it’s sufficient for big projects but i did run it for a few days just with 1-2min project files. It was a thrill to see. The specs on the compressor sticker say 6.4 cfm at 90psi, 8.6 cfm at 40 psi. I have started to look into quieter ‘affordable’ models I might tie together with the craftsman.

No. No joy. :disappointed:

Yes you need a bigger compressor for sure. That will never keep up on larger cuts

1 Like

The plasma should always be on 2t for CNC use.

If the air blows and the pressure is good, then the electrode is not moving to initiate the arc. What type of clamp are you using on the torch and where is it clamped? If it’s clamped near the bottom of the torch, you could be compressing the internals and preventing the electrode from moving.


Man. I had overtightened the bracket! That was it. I’m up and running again!! Here is the position of my machine torch bracket. I simply loosened the bottom a bit and it worked. Thank you!


You have your torch mounted wrong.

You also need to put the work clamp on the work piece not the slats.