Razorweld 45 misfire help please

So I have maybe 8 hours tops in last 7 month’s cutting…

I have been down 2 weeks now (real job and life takes over…BUT…) so I was cutting 14ga for a prototype portable pizza oven, cut 10 pcs out of a pc of 4x4 sheet. No issues, worked great at 30amps 120ipm.
Stopped, switched to 3/16 sheet, 45amps and 35ipm

It cut 1pc and at end it looked like consumables went bad…changed them out,tip and electrode looked nasty. It wouldn’t acr, lost voltage alarms etc.

I tried to air fire torch 30 times, nothing. Checked continuity between short trigger leads on torch mount, switch works fine.

Air solenoid works fine.

Any ideas?

Left message and emailed them on Tuesday, no response. Tried calling a few minutes ago ,closed

I need to cut 6 more pcs…this sucks…550* oven isn’t hot enough :crazy_face: :pizza:

Can’t say for sure but if you call me I may be able to help you.

machine torch or hand held?
check the pins inside at the cup…

1 Like

Definitely. That’s why I designed & built a wood fired brick oven. The plans and a lot of build doc are out on the web (search for “Pompeii oven plans” or “Jim Hatch pizza oven plans”). There’s also a good little forum of builders. Almost all of the materials are available from Home Depot and total cost was about $1000 with 2 or 3 weekends of work. Or PM me & I’ll send you a copy. They’re free.

I’m a huge thin crust pizza fan so I know your pain :smile:

Thanks ya’ll, we have a 36" wood fired I built outside, it takes about 3hrs to get to temp, we do love our 45 second pizzas tho :star_struck:just wanted a propane fired one We can take on boat and use every night.

So it is a hand torch j45h, been using mechs tips/electrodes no issues before.

This is tacked together, 2 pc top/bottom

Just need to fix plasma, waiting on razorweld to respond. Are there fuses? It cut all the above fine, until I cranked up to 45 amps for stone supports.

I can’t help you unless you call me!

1 Like

I didn’t want to bother you on the weekend…:stuck_out_tongue:…pm me a number. Wife needs to go take care of her mother at lunch so I got time. And THANK YOU so much

Is there any way you can get rid of some of that thermal mass? Mine takes an hour to hear up. It was one of the design parameters I was trying to meet (I had 4 kids and they wouldn’t wait 3 hrs for anything :slightly_smiling_face: ). I built a propane fired forge burner to speed it up more when I wanted quick pizza. It throws off 100,000 btus and takes 15 minutes to heat up.

I expect you have so much mass to heat up that it takes a long time. That’s okay for bread or other longer cooking food but pizza doesn’t need that much mass (unless you’re commercial and need the oven to run 10 or 12 hours so you need to keep it warmed up after shop hours).

Did you get the problem figured out?

Been out of town on a work emergency and dropped my phone, gotta get to Verizon this week.

No fix yet, problem has sat since last weekend, George :beer: is on me if we get to meet. Stand up guy :ok_hand:

We spoke for a while and I tried some things he told me, took apart torch handle and disassembled and cleaned plunger. It looked like it was brand new.

Razorweld replied and am waiting on a support email hopefully tomorrow.

Tried the hit trigger a million times, nothing.

The plunger “clicks” in 1 way but just smoothly disconnects so you can push and click again.

Only weird thing was instant melt down of consumables in about 10inches or cutting

Will keep posted

It was designed to cook bread afterwards so we would all have bread to take home after holler pizza parties (similar to block or neighborhood parties. Just more country)

But we ended up to full, happy and loaded with hops, and grape juice that bread just never worked out :rofl:


I buy my consumables from mechanic416 and am very happy. I had kinda the same problem ; my torch wouldn’t fire, just air. like a dummy, when I change the electrode and tip I got the swirl ring in upside down. Just thinking!

will check!

So it’s been a few days with no follow up, are they on this forum? @langmuirsystems

Did you try calling them ?
+1 253-859-6277
+1 253-859-6278

Wife tried through facebook (no response, altho she said she didnt know what she was doing :rofl: )

I work 12/14 hr days, I will try at lunch thanks!!

Tried several times after work but it is late for West coast

They are in the state of Washington.

Send them an email through their support line in the main site
They do not read every post

After talking to Razorweld last night and George over the weekend

I took apart torch to check it out again. I was told this plunger needed to move freely. It uses a spring to let it float back and forth, I cleaned it and it moves freely

I cleaned and inspected the insulator and all looks good

Cleaned this end also

Now I assembled to check clearance and discovered this, with pcs just sitting on each other there is about a .090 gap?

When pushed together like cap will do, the plunger is bottomed out.

Everyone said the plunger needs to move freely, why?

To take up slack from electrode wear?

Do I have the wrong consumables?

Is it assembled wrong?

Could this be my issue with torch not firing?

The plunger has to hold the electrode against the tip till it gets air then it push’s the electrode and plunger back and starts the pilot arc.

You have the wrong consumables.

1 Like