Razor cut 45 problem

I got the machine up and running and wanted to try a couple test cuts, torch fired fine for the first few cuts then I couldn’t get it to fire again via trigger or Mach 3.

Then as I’m tinkering I see the arc initiates if I touch the work with it. I’m assuming pilot arc won’t initiate. The light on the machine lights up when trigger is pulled or started from machine 3

Any ideas

How dry is your air and have you checked your electrode

Although not ideal it’s through a desiccant dryer, and tried new consumables. I got about 2-3 cuts and then the pilot arc wouldn’t initiate. I cracked it open, found one of the connections for the pins on the torch just laying inside the machine, put it back but still no luck

I use a desiccant dryer just bleed my line periodically, dry and change out accordingly. Ide double check any loose connection and your torch height to material (.06) is ideal

1 Like

What controls the pilot arc starting? Is it a process within the torch or is it something on the board? The arc will shoot out if I touch the tip to the work, but the moment I pull it off, the arc extinguishes

Well, I admitted defeat, got in touch with George over at George’s plasma cutter shop, he’s gonna diagnose and hopefully be able to repair and return. In the meantime I was able to order a harbor freight plasma cutter off eBay for stupid cheap to get me by. The way I view it is I’ll have a backup should anything happen again

some Horrible Freight cutter aren’t supported

We are no longer able to recommend the following Plasma Cutters as compatible with the CrossFire.

Lotos Supreme Cut 60D
Lotos Supreme LTP5500D
Harbor Freight / Chicago Electric v1
AHP AlphaCut 60
Interference generated by the power supplies of these cutters have been known to cause issues with CrossFire electronics. Owners of these models who wish to use their cutter with the CrossFire must take further steps to ensure proper grounding and resistance to EMI in their systems.

Use of these cutters is not supported by Langmuir Systems and is at your own risk.

How do I tell which one I have? I see v1
Are there others?

Never mind, looks like the older (blue) harbor freight cutters are out, I ordered a black one. Think I’m good

I had that issue - I would up swapping tip and electrode to harbor freight’s and haven’t had a problem since. I kinda wonder if some of the 45s shipped with the wrong tips or electrodes from the factory, almost like the electrode was the wrong dimension to be able to initiate the arc.

Possibly, but the torch was working with these tips and then wasn’t

Now that I think about it, I recall George from the plasma cutter shop mentioning some fiasco with razor weld and their tips, saying their tips would work but technically aren’t the appropriate type for the torches

Yeah same exact issue… Mine worked for a little bit… then didn’t.

It sounds like most people with the 45 are switching to a 1.0mm tip. Apparently the 45’s come from the factory with a 0.8mm tip that is only rated for 30 amps so they are easily blown out by the 45.

1 Like

That and it looks like what razor weld sent out with them are consumables for s45, and not ipt-40.

Was just at harbor freight and their torch has ipt-40 on the side, probably why some are having better luck with those electrodes and tips

Also they are .9mm tips

Why would an ipt-40 consumable be better? Razorweld says to use ones compatible with Trafimet S45 torches.

Pt-40 torch on the left, s45 on the right.

My razor cut 45 has the left torch

Huh. Mine has the right torch.

Unless they’ve changed them recently, I didn’t get mine with my preorder, had it before.

I got mine with my Crossfire - well it came earlier, back in late Sept. The Crossfire table itself shipped later.