PSA: Regarding "Child Process exited with error code 1"

It looks like this video specifically helps with the issue occurring when trying to run scripts within CMD, this likely wouldn’t help in the case of a full application like FireControl. I’ll do some poking around though!

3 Likes

Always appreciate your involvement on this forum @langmuir-reilly!

You are probably busy burning the candle at both ends now. Watch out or you will be filling up your days like Tin does.

1 Like

I guess I’m one of the unlucky ones with a non-Intel “-H”. AMD Ryzen 7 5800H in this case.

You’re not alone. I am one of the unlucky ones too. I’m new to plasma cutting (both cnc and manually). I was so excited to finally get the plasma torch working and setup. Now I can’t open FireControl on my new laptop that I purchased for my CrossFire Pro. Ughhh. I pulled out a very old HP laptop with an Intel graphics chip. Installed FireControl. And happy day! It worked. It isn’t a fast computer, so I’m a bit worried that it might stop or buffer in the middle of a job. My fingers are crossed.

If the new laptop has a power-saving CPU chip, that’s probably the problem—for example, i7- 10900U, that U is your huckleberry. The design of new laptops is to save energy. The child process fault is some Windows Voodoo that some IT geek may explain.

1 Like

You will probably be fine since there is really not a great deal of information flowing from the laptop to the table.

If that fails you, BigDaddy has a good and inexpensive suggestion for you:

I seriously considered that but I sort-of needed a computer that would also allow some design work on Fusion 360.

2 Likes

I’m using this Mini for another project and it works quite well. Easy to setup and reliable.

2 Likes

Is this issue actually going to get fixed?

I’ve managed to block updates for over a year on windows11 until something randomly changed and Microsoft didn’t anyway… Requiring me to waste hours trying to recover, reinstall, etc.

Guess I’ll just have to throw more money and buy another mini PC at my MR1 since apparently the software won’t actually be updated to run with Windows updates on modern processors with power management.

Windows updates are not the problem. Like the thread before. Let us know what chip your computer is using—for example, i7 11700 and then some letters.
Suppose the letter is a U or an H. That is your problem.
It has nothing to do with Langmuir software.

A “child process error” is a generic Windows error message that occurs when a subprocess created by a program – the “parent process” – runs into a problem that prevents it from completing its task. In the case of FireControl, the digital read-out and toolpath visualizer are examples of child processes. These errors can occur for various reasons: insufficient system resources, hardware failures, CPU driver issues, etc.

2 Likes

Good afternoon @Barge! The way @Bigdaddy2166 explained it hit the nail right on the head. I have sometimes seen this error occur just from having two instances of the same program running. If you haven’t yet, reach out to us at support@langmuirsystems.com so we can gain some more detail and help resolve this!

3 Likes

I don’t think I can agree that is has nothing to do with the software.

My mini PC worked fine with the original installation of windows11. If it does any upgrade/update the cut control software breaks and get a child process error. If windows makes an update and changes the way a process is run or whatever… guess what. Developers need to update their software to accommodate. I specifically bought a very capable mini PC so that I would not have issues. Little did I know that having an AMD processor with power management would mean that in regards to cut control it’s a brick.

I tried every trick in the book to block updates on windows 11. I’ve spent hours and hours recovering, modifying registries, making business policies to stop updates, and/or try to get this process error resolved. Windows somehow decided it was going to update anyway. If you’re going to make windows based software you need to deal with all that comes with it… which includes Microsoft changing how things work.

So now i’m buying the mini PC that you recommended above so hopefully I don’t have to deal with this issue again… well until windows does another update…

In 20+ years of controls engineering working with the most random software and dealing with hundreds of compatibility issues I’ve never seen a child process error until the MR1 and I don’t find it acceptable that to just say “sorry you can’t use that processor that when you bought it we didn’t have any specs listed that said you couldn’t use it so sorry for throwing away that $200”.

I don’t think i’ll be the test dummy, early adopter for the next extremely expensive piece of equipment I buy for my garage. I have to spend enough time on actually learning how to machine. I’d rather not waste it being an IT guy.

But anywho, hopefully the new PC fixes it and I never see this issue again.

All I can tell you is the three that I use work perfectly. I’m sorry that I even commented on this issue.
Best of luck to you

3 Likes

You can stop windows updates. Turn off your internet connection unless you can’t operate without it.

2 Likes

There’s lots of things I could do…like buy a whole new computer like I did as recommended above as one that works.

But my point is that I shouldn’t have to… If people wanna just say “well I only spent $7k so I’ll deal with it” then fine.

There’s also a bunch of people in the mr1 converting their whole control system to something more stable. So I’m not the only one that feels this way.

If nothing else thanks all for the posts in this thread that at least pointed me to a mini PC that works.