Problem after problem

I have had nothing but problems with this table and my frustration level is pegged. I can’t seem to get through a single job without a recurring or different issue popping up.

TODAY. I started a job and halfway through the torch (Razorweld Cut 45) stops firing. Changed out the tip (old one looked fine) and started the job over. It stops again halfway through albeit in a different spot. It’s as if the cutter is eclipsing it’s duty cycle which seems unlikely. I’m working on 16ga sheet. The completed portion looks perfect.

Has anyone encountered this? Any trouble shooting tips?

ok…we have all have levels of frustration…and we all try to help…

look at the following items and answer if you can.

OG table or Pro Table
do you have THC?
have you always had problems or is this a newer issue?

Laptop or PC running the table?
make sure PC us ungrounded and the laptop is not plugged in

do you have clearance between the the Plasma unit and the control box?
do you have ferrite chokes on your USB and other lines?

are you clamped to the material or the table or the slats…always to material…clean metal for clamp works best

are your lines and cables nice and orderly?

does the table keep moving and just the torch cuts out?..or does the torch cut out and they both stop?

Are you running FireControl or Mach3?

How is your air pressure during the cut? it running out of air?


Basic Table.

I started with a HF cutter (mistake) and recently purchased the Razorweld. I completed a complex job with the new cutter.

Laptop. Using a program called SignSlapper for a .dxf, then SheetCam, then Fire Control. Post program and dry-runs work fine. Not sure what you mean by ungrounded and plugged in. It runs off the battery and is only connected via the USB cable. I set the laptop on an adjacent plastic folding table. It’s as far from the cutter as the cable length will allow. Cables are not “routed” per se, they are draped from the control box to the motors.

Ground clamp on the material, not the table.

I have no idea what ferrite chokes are so I doubt I have them.

THANK YOU for you lengthy response. I appreciate and await your answer.

The program keeps running but without the torch firing. I manually pulled the torch trigger and it fired. I have noticed that the air pressure does blow a fair amount of water up on to the metal.

I have an industrial style compressor that is capable of 22cfm at 120psi. I doubt its an air supply issue

1 Like

What are you doing for drying and cleaning the air supply?

Video or pictures may help.

Nothing. Is that important?

1 Like

Will this work?

Check your air supply. Below pressure or CFM will cause the issue you describe.

1 Like

I’m fairly certain air supply is not an issue. I have a big, two-stage Denver-Gardener compressor capable of 22cfm at 120psi

1 Like

google ferrite chokes…they go on the cables…they do help.
air supply if not dry and well filtered can cause all kinds of problems
how close id you plasma to the cables and control box…plasma give off a large electromagnetic interference…ferrite chokes and distance apart help that.

good to see laptop not plugged in when cutting.

since you are using Firecontrol…have you done the testing in firecontrol …THC control test button…check that also

1 Like

I did Google them and ordered a set of six off Amazon in the last hour, along with a water filter/separator.

My table doesn’t have THC. should I still run the test?

if you do not have THC then you do not need to…

Yes clean dry air is critical. If you post pictures of your consumeables we will be able to tell if contaminated air is ruining them prematurely.

What you posted is probably not enough to clean the air, most people run a copper manifold at the least, or a refrigerated dryer. A motorguard filter is the last item for most of us. Oh and a desiccant holder.

1 Like

What cable(s) should the ferrite chocks go on? The USB from the laptop to control box I understand. Any others? All of them? TIA

I have them on almost every wire…

Thanks. As inexpensive as they were (from Amazon) I’m a little surprised that Langmuir didn’t include them.

I guess where I’m confused is, as mentioned, the torch stops firing halfway through. When I run the job again with the same tip, it cuts nicely until it reaches roughly the same halfway point.

My setup does blow a fair amount of water up onto the sheetmetal. The tip passes through the puddles. Is that an issue? Should I lower the level of water in the pan?

Water in the air supply can be a problem, but water on the material surface won’t bother the plasma arc. On thin material, I actually spray a stream of water directly at the arc. The air velocity is so great that whatever visible water you are seeing is blown out of the way.


Maybe someone can add to this but I believe I read that there is a fix/modification to the RW45 to rectify this issue? Something with a jumper, maybe? I run a Hypertherm so didn’t get too deep into it, but there were instructions on the Langmuir site. Again maybe someone can add to this, whether it is even relevant. Also, in terms of a water separator, what you have would be the minimum. I don’t believe this is your issue but you may want to consider a Motor Guard “toilet paper” filter just before the plasma. Again, I don’t think it’s your problem here, but when you get going it will help immensely with your quality.

Here is the link to the bulletin: RAZORCUT45 Misfire Issue - RAZORWELD TECH BULLETIN 9/23/2020


Posting a video is the next step if you want help solving this.

I had alot of frustrations with my table as well, that is until I put the chokes on my usb cable. THEY WORK!!
I still get an error or two here and there, but nothing like before.