Primeweld cut 60 thc no voltage

Hey everyone! I just finished assembling my crossfire pro and set up my primeweld cut60. I have the torch firing wires soldered to pins 1 and 2 on the cut60 adapter and the thc to pins 4 and 6. Im using the machine torch. I ran the thc test and it fires the torch but after the test it says that I have no voltage detected from the machine. I’m wondering if the USB is interfering with the voltage or if I’m doing something else wrong? I used a ohm meter and found there is some continuity between the USB and chassis of the table. Should I buy a USB isolator or a cord with more choke. I apologize if my question is a dumb one, I know absolutely nothing about cnc plasma tables nor do I have much experience with electronics… I’m a pipeline/rig welder just looking to expand on my fabrication knowledge and make some extra coin on my down time.

1 Like

Well the Cut60 was removed from the compatibility list as discussed here:

However, I have a Cut60 and I have not had any issues with it for over a month now since since I completed assembly. The only mod I made during assembly was isolating the electronics box by mounting on a piece of wood and then to the table leg. I did this because the plastic insulator strip and washers were funky and not very sturdy. I can’t say this would solve your issue.

You should search the forum. There are several topics about this and similar issues.

1 Like

Thank you! I’ll keep looking into it

Was you trying to cut metal? If you were firing the torch in the air there will not be voltage.

1 Like

If you are not getting any voltage at the THC, but voltage exists, it could be as simple as a loose termination or connection in your CNC cable or VIM cable. Check those first. The solder connections on the machine side of the CNC are pretty small and frail and more than one of us had one come loose. Also, get a multimeter and check resistance from the DIV IN to DIV OUT of the VIM. If you get a high reading there, the VIM is bad.

1 Like

George, the THC health check in FireControl reads voltage dry firing/firing in the air. Not sure how it works, but it’s designed that way.

Yes you are right there is voltage. Its reading pilot arc voltage from the electrode to the cutting tip. But that is not true voltage until you have a complete circuit between the work clamp/ground (positive) on the metal and the torch (negative).

I also recommend pins 5 and 7 over 4 and 6 or open the plasma cutter and connect direct to the terminals inside the plasma cutter

That’s another thing that has me stumped. I took the plug apart and all my connections are good and I’ll have to try checking the vim

Probably should check continuity from end to end of the cables. As far as that continuity, yes, you should address it. It’s usually that the shell of the connector is touching the motion control enclosure. You can just fold a piece of electrical tape to make a shim, skootch the USB receptacle enough to fit it and let go. The pressure will hold it in place. Check continuity again.

Will do I will get back to you folks Monday and let you know what I find out. Thank you guys again for the help.

1 Like

Make sure that you have the polarity correct on pins 4 and 6. Incorrect polarity will cause the votlage to read zero in FireControl. Its an easy mistake to make.

Also worth mentioning that we are in possession of @Jemejia old CUT60 and found that the voltage it outputs is over 16vdc when firing. That is what fried the resistor network in his VIM (and 2 others that we know of). Because of that i recommend that you wire the Cut60 directly to the raw voltage lugs inside of the plasma cutter case.

Fantastic news that you are getting some ideas of what is going on…

@langmuir-daniel Cue the country music:

Well, you can have her.
I don’t want her.
She didn’t love me anyway.

Not trying to hijack here but I simply can’t resist posting this little ditty from 1961 for @TomWS

@KX9M I had the Sam Neely version in mind myself.

1 Like

Well I just tried pin 5 and 7 the test concluded that I have a live voltage of 25v and that was too low I then disconnected my laptop charger and it 300.0v which was too high

I re connected to pins 4 and 6… this time I left my laptop charger unplugged and everything works haha. Thank you everyone for your help! I’m sure I’ll be asking more questions I’m the near future.

1 Like

I am glad you got it working. Langmuir is working with Primeweld to get this fixed.

They must have had some updates to the plasma cutter that is making things not work right.


yup i’ved been saying that all along. they must’ve switched some components within the last year or so.

What is VIM