Please help me with my Razorcut 45 and THC

Crossfire with a water table that I’ve been using for about 3 years. Using Razorweld 45A plasma cutter. Typically cut 3/16 mild steel and have had great results. I installed Installed the XL upgrade kit and THC/Z-axis upgrade as well. So far I have had to replace the drive screw coupler in the z-axis assembly due to the motor shaft spinning in the coupler that came installed. Luckily was able to find a replacement one on Amazon for cheap and quick. All three axis now operate very nicely.

I designed a new cut program/part in Fusion 360 with the suggested settings provided by Langmuir and Fusion 360 defaults for the pierce time, pierce height, etc… Pretty simple shapes just for testing the new upgrades. Upon running the THC test function in Firecontrol with my design loaded up, I’m running into trouble.
The first message looks “ok”

The second message was first saying that 0.0 voltage was detected even though the torch did fire on command during the 3 Fire and Arc-on sequence.
So I switched the red and black wires on my CNC port at the front of my Razorweld and ran the test again. The torch fired and I confirmed arc 3 times in a row as instructed. Now I have a message saying that my voltage is detected but is too high.

Front of my Razordweld:

Razorweld Build Date 03/27/2019

I have looked through troubleshooting guides, but still am a little lost on how to diagnose. The troubleshooting guides that I’ve looked through say to test voltage with a multimeter while the torch is firing… Can’t do that if the torch won’t stay firing. I am flat out losing money with every day this machine is down and need to get it up and going again. I tried calling Langmuir, but they are email-only for the issue(s) I’m having. I would greatly appreciate any help!

I don’t have the Razorweld set up, but I am sure others will chime in soon.

If you have to get cutting, you can deactivate the THC in FireControl and just cut with the IHC setting the initial height. You should be fine if you are cutting 3/16" material.

As for the THC issue, looks like you are grabbing live voltage instead of divided. Live voltage has to be reduced by using the proper ports on the VIM box. Others more familiar with the Razorweld ports and setup will have to provide more detail.

How is you vim plugged in?

Your plasma cutter to DVI input.

And then from DVI output to your electronics enclosure?

DIV input from port (CNC?) on Razorcut. I originally had the black wire from the plug pigtail to the black wire in the CNC port and the red wire to the red wire. Upon the Fircontrol test saying that was 0.0 volts during the live voltage test, I unplugged and cut the cord to switch/reverse the wires where you see the pink electrical connectors in my picture above DIV Output to Langmuir enclosure port

YESSS! I got it figured out and working after almost two weeks! I contacted Langmuir and they had me run several tests to see the voltages at my Razor Cut 45 CNC port. Upon completing all of the voltage steps (step-by-step instructions link for testing continuity between electronics enclosure and Crossfire table, and step by step instructions for testing Exact Voltage Measurements here

I had no grounding issues or continuity between my electronics enclosure and table. That was an easy test with my multimeter.

After running the next set of tests (multiple times) I found the voltages and then forwarded them to Langmuir. Each voltage test was significantly higher than they were supposed to be. Langmuir said they were twice as high as they should be.

Their suggestion was to contact Razorweld directly. This was a little disappointing since there wasn’t just some switch I forgot to flip, but contacting Razorweld was incredibly easy. I went to their website and found a link to email them, but I also found their direct contact number. In case you need it, the number is +1 253-859-6277 and they are located in Washington state (pacific time).

Upon calling, I got to speak with a human. As I was explaining my situation, he interrupted and said, “you must be calling about the voltage divider in your Razorweld Cut 45.” I agreed and he told me that I will have to replace the motherboard inside the plasma cutter to convert it from the 20:1 voltage divider to a 50:1 voltage divider. Either that or replace the entire plasma cutter. I asked about the cost and was told that they could send me a new motherboard for around $230 with shipping. THAT’S WAY BETTER THAN THE COST OF A NEW PLASMA CUTTER! I said, here’s my card number, please get it on the way!!

The new motherboard arrived about a week later. I had to tell a few customers that there would be a slight delay in their orders, but only a week or so… Anyway, I opened the box containing the motherboard and thought to myself, " Wow! You may have bitten off more than you can chew here Adam…" I decided to take a chance and see how hard this was gonna be. I took pictures of every single step I took including removing the screws and pieces of my Razorcut 45.

Although very nervous that I was gonna screw something up, I cleaned my hands and turned on some classic rock, and began unplugging and unscrewing every little connector as I came to them. Reassembly was reverse of removal and only had to solder two little wires from the CNC port to the new motherboard

You have to take the plasma cutter completely apart to do this modification, but don’t be scared, it ended up being fairly easy. Just glad that I had pictures to refer to. I cleaned up the internals of the machine as well. I couldn’t believe all the dust that was inside my Razorcut 45!

Afterward (the next day), I plugged everything back up to my plasma cutter and Langmuir Crossfire. Upon trying to fire the torch, all I heard was a “click” inside the machine. I began to freak out and called Razorweld. The tech guy helped help me figure out what the problem was. After explaining what was happening, he asked what my pressure reading was on the front of the Razorweld. Embarrassingly, I replied, “It’s at Zero.” I then realized that I had forgotten to turn my air back on!

I ran the THC Test again in Firecontrol. The resting voltage ended up being 0.0volts. Perfect! I then ran the Arc-on test and the voltage is now running at 122.4 volts. Perfect again!! I ran a few test cuts and see that everything is working as it should!!!

Now just to perfect my drawings and do some cutting!

Big thanks to all who helped here on the forum and at Langmuir!

If anyone needs pictures of the steps I took to replace the motherboard, please let me know.


this is great news…and thanks for sharing…
it is always great to hear and see that people can get problems fixed…


Did you know that the Langmuir supplied VIM box…the little black box you get with the kit…the one that has RAW and DIVIDED voltage inputs…by taping into the RAW voltage inside the case where the leads go out the case and putting that in the TORCH and CLAMP…would have done the same thing…and saved you $230 and all that fun taking it apart…


Using raw voltage did cross my mind, but after Langmuir suggested I contact Razorweld and then Razorweld said they had a sure fire fix, I just decided to go that route. I’m really excited to start cutting with THC. Cleaner cuts and less wasted metal hopefully!

hey…what ever makes you cut…the great thing is the amount of trouble shooting you learned and can hopefully pass on to other people…

start burning metal…