Plasma cutter wont stay lit

Hi new the forum. Just got my table ready to run but having issues with my razor 45. I tried to do some cutting with it today and it will only cut about three inches . Then the tourch will go out but the air keeps blowing out . It will countinue to run the program til the end but then will just sit there and discharge air. I can push the reset,the stop button but it keeps discharging air the only way I can get it to stop blowing air is to shut off the plasma cutter. Also when the program is running indicator light will light up and turn off like it should in the program.

1 Like

I had a similar issue like that when I started and it turned out that I didn’t have a good ground on the workpiece?

Good luck


I am having the exact same issue. I tried many things, changing material thickness, adjusting amperage, adjusting Air pressure, but no results. I even went to the effort of hard wiring my torch on/off inside the cover of the Razorweld 45. Mine has the 2 auxiliary ports on the front and whether i use the prewired port, or the hardwired harness, it doesn’t change anything. I have tried grounding to the drain, slats, and the work piece with no success.
I ordered more consumables and will try again today in the case that i ruined the nozzle.

The first thing everyone need to do when this happens, is to disconnect the plasma cutter from the controller/table. Take a piece of metal hook up the work clamp and try cutting out something by hand, with a few stops and starts. If the plasma works by hand then the trouble is in the program of controller.


Try putting a piece of scrap material in place of your cut material, run the torch over the top of it and stop it. Squeeze the torch trigger and see if it fires. This should at least tell you where the problem lies.

Just had this happen to me.
Everything seemed right, but, torch electrode consumable had melted away. Changed the electrode, ended up also changing the inboard air water filter, it was clogged, so I cleaned the bowl, and replaced the filter, thing cuts like Darth Vader’s light saber.
I believe what started the issue was cutting some metal with surface rust on it, and not getting it grounded good, then thing dominoed into the total issue.
I have never cleaned the onboard filter in the 3-4 years I have owned the plasma cutter. Did not even know it was there.

Thanks for the advice today i was able to get back to it . So I unplugged the table grabbed a piece of scrap metal and hooked the ground right to it. I tried several starts and stop cuts. It worked good for short cuts but with long cuts it will still cut out. I tried to adjust amperage and air pressure but still got same results. I’m going to run to my look weld shop tommorow and grab some new consumables and try that.

well, the first thing is CLEAN, DRY AIR! Water will destroy your consumables in a heartbeat… I have 3 inline filters, including a motorguard, AFTER my refrigerated air dryer! Yeah, I may have went overboard, but I have ZERO water issues… ALWAYS ground to your workpiece! Not the drain, Not the table, Not a slat, Not the water table… THE WORKPIECE. I have (old age) ofter forgot to clamp my workpiece and left the clamp laying in the water and I’ll wonder why my cuts look like shit, then I see it laying there… It really does make a difference!

If you know you have dry air, and you have it grounded correctly, then check your consumables. And consumables include the cap, and the O-Rings (if you have them) inside your torch when your remove the cap… Ask me how I know… I chased that problem for a month! LOL

After that there are any number of things, but a lot of it also has to do with how level your cutter travels along the volume of your machine. If you start in the lower left corner with the small shim and end up at the upper right corner with the large shim as a gap, or even smaller, it’s gonna be an issue… So squaring up and leveling your machine is pretty critical. That distance between cutter and material is pretty important for good cuts. It’s like Goldilocks, you need it just right (with a SMALL margin error). Thats why I added Z-axis and THC from the day I got my table.

If all that stuff is right, then I’m outta answers…


It turns out that my main wiring harness was faulty. My unit is brand new and I have yet to cut anything successfully. Took 3 days for langmuir to address my concerns. And another couple days for them to get the part out. Has anyone else had customer support issues? I see a lot of positive customer support reviews, but so far I haven’t been impressed.

Like I said before, always test the plasma cutter on its own to see if its the plasma cutter or table control.

That’s a little longer then they normally respond.

1 Like

They are usually faster, but with the PRO shipments in full throttle, I’m sure they are all overtasked at the moment…

@Blueline something to consider if you discover good manual short and long cuts.

I want Darth Vader’s saber, but all I get is flame cut out. So far all suggestions have availed nothing. Voltage good, air good, 2T setting, as good a ground as I can. Can humidity really be an issue. If so I’m F’ed because I’m in Central America.

Update: Richie in the warehouse at Razorweld took several calls and got me straightened out.
The key thing that I hadn’t seen anywhere in the literature, or mentioned… is that , with the “hypercut” torch tip, you have to be touching the material. No off set.

another thing that became very apparent was humidity. Being that I’m in Costa Rica and the humidity rarely drops below 80% I’ll be adding some in line filters.

can you take the torch off the table and do freehand cutting?
that will help determine if it is crossfire or another issue.

there are many ways to deal with moisture no matter where you live…some chaep and some not so cheap.

moisture mostly errodes the plasme consumables…less life span…it should not stop the torch from running.

1 Like

hi. what do You exactly mean by “disconnect the plasma cutter from the controller/table” ?

I have similar problem - have bought straight torch IPTM-80 - so I can cut some precise holes with My Ortur Laser Master 3 (normaly used for laser engraving and plywood cutting and so one) into steel parts - mostly big diameters which are difficult to drill.

When original 90 degree hand torch with switch is used - it does work like expected. I can start pilot arc beside of material (or into predrilled hole - so the nozzle doesn’t get blowed with molten steel from back-blow) - and when it reaches the material it follows with normal arc until stopped or run behind material.

But when used with the IPTM-80 - it only works when started above steel - so the pilot arc self penetrates the material and cuts forward until stop or end of material.

When IPTM-80 is started beside of material - pilot arc starts - but immediately after it “touches” the grounded material it shuts off immediately… :frowning:

Pins are on both torches same (1-4 pilot arc, 8-9 shield cup) - the IPT-60 has 2 shorter pins 3-5 more for hand switch. All other is same on both torches.

To start using it I use back 4-pin connector - I use manual switch (pins 1-2) - machine is HEROCUT CUT55i (it has cnc support).

I think pilot arc has other color from normal arc color - but I can be wrong (color change on material contact ?)

Has somebody observer same behavior like in My case please ? If so, how to correct this ?

I don’t see difference between the two torches (in concept of number of pins except 2 more for hand switch on handle on IPT-60).

Thank You.

HEROCUT 55i plasma cutter with a ipt 60, 60 amp torch. So why did you buy a iptm 80, 80 amp torch? When you only have a 55 amp plasma cutter? Were did you get the iptm 80 torch? If you used a ohm meter and made sure the pins are really what they should be then they are wired right. Of course a machine torch does not need trigger wires as it gets it trigger from the CNC controller to start the pilot arc. Pilot arc only last for about 2 to 3 seconds. So unless its not getting to the metal in time to start the cut there is no reason the it should not start the cut.

hi. if You are same mechanic416 like in the other forum, then read there please - Help!! Plasma Pilot Arc fail to transition to Cutting Arc if You can give approval or other thoughts to the theme.

the reason to buy the iptm80 was to have interchangeable spare parts with the ipt60 torch - and perhaps one plasma cutter device more for more advanced CNC cutting in future, when the whole cnc plasma cutting thing will look perspective for Me - I don’t want to destroy My Ortur Laser Master 3 device I bought for laser engraving and plywood cutting ideas… and, for to be precise in the meaning of 80 amperes - I should first change My house primary breaker to something more useful - something about 100 amps. and not 25 like I have novadays. and because I have 3 phases, I should very good think about the whole house breaker change - it is not cheap to do that in Slovakia… and without future profit on My own devices “in house” it is not profitable to do such big change on house (I should then also change whole wiring in house - at least the power wiring into workshop part…) - and then the power distribution company can ask for whole wiring change and other things… very complicated to do that here…

p.s. I cut mostly thin sheets at the maximum of 20 amps. or only some precise circles and plasma cutting of these is much much more cheaper like to drill them with very special drills which are too expensive. You best know if You have plasma cutter You have universal diameter drill… the CNC was only logical evolution of all the things together…

This is how it’s supposed to work. If you don’t want to operate the plasma cutter like this, find another way to cut things.


it is an option. if I would like to save the nozzle, then I would like to create pilot holes with common drill for example 3mm in diameter, so no back-blow occurs…

by lowering the pressure it works like it should - pilot arc with transition to cutting arc when material “touched” by the pilot arc…

look at the videos in the link to another forum… there are all common possible situations recorded

and here video with original hand torch IPT60 - on 3mm square steel tube with pre-drilled hole to overcome blow-back (and save nozzle)

positioned direct over the hole - and after a second it transitions to cutting arc and cuts the pipe…

The nozzle will wear out regardless. I’d rather pierce the material than trigger the pilot arc over nothing. Holding the pilot arc will actually decrease consumable life.

The only exception is when you need to do an edge start for very thick material. Even then, it’s an edge start not an open space start.