Plasma cutter won't fire (PowerPlasma 52i)

So I have a Crossfire Pro with THC. I was able to stumble fumble and finally get it assembled. My cutter is a PowerPlasma 52i with CNC port. I followed the information available on the site and soldered together the communication cable. I am able to get a voltage from the THC controller, reads like 59v I believe, I will double check when I get home and edit OP for correct reading. I had to use sheetcam as fusion 360 would not work on my PC for some reason. Fire control will load these and trace the program but the plasma cutter WILL NOT activate and cut. I am at my wits end on this. I have turned away a bunch of potential work on this and need to get this sorted.

Help me Obiwan Kenobis - you’re my only hope.

First the THC has nothing to do with the torch not firing. Lets get the torch to fire first. Are you using a hand or machine torch? What is you air set at for cutting? Are you wires to pins 1 and 2 on the CNC port? Did you check the torch fire relay in the control box? does it click when you command the cnc to fire?


@mechanic416, Firstly Thanks for the reply. I should have stated that I can manually operate the plasma cutter without trouble.

Hand Torch.
Can confirm wired pins 1 & 2.
For the relay everything looked correct, how can I double check this?
I cannot confirm a clicking when trying to manually fire with the program. I will check this shortly.

Hey Michael,

If you reach out to us at, we’d be happy to help there as well!

1 Like

Just got home and yes, the relay clicks when attempting to manually fire through the program.

@Harmir229 welcome to the forums.

Is fire control displaying any error for you?

@TinWhisperer Thanks for the welcome, and I get no errors when loading and running programs. Also no errors when doing the enable/fire command in fire control.

On the front panel of your plasma what mode of operation is it set to and is it throwing any error codes?

Settings on the 52i

25 amps
65 psi
10.5 post flow
CNC is selected
Auto Restart is selected.

Where is the cable that is connected to pins 1&2 plugged into? It needs to be plugged into the torch on/off port on the electronics enclosure. For some reason people think it gets plugged into the VIM box.

Also, it needs to be fully plugged into the port. Some people have difficulty getting it pushed all the way in.


well… now I feel like an idiot. That was it. Swapping which cables went into the VIM and Torch on/off ports fixed the not firing issue.

I was able to successfully cut a test coupon, the entire program was not successful due to the settings of the program loaded (pierce delay too short) but I am going to take the victory by inches at it is.

Now the issue is the THC. it is reading a solid 0.0 volts now.

Edit. Material is 16ga steel.

Ok. Let’s go over what you have plugged in to the VIM.

If you are tapped into the divided voltage on the CNC port, that cable should be plugged into DIV input and another cable goes from DIV output to the electronics enclosure THC port.

If you are doing raw voltage, those cables plug into the color matched ports on the face of the VIM and a cable goes from PV output to the THC port.

You should see 0.0 volts with the machine idle. There will not be any voltage until the Torch fires.

1 Like

Ah ok. I wasn’t paying too much attention when the program was running. I will be sure to check when I run my next test cuts

Edit. I running through the CNC port to the DIV input.

1 Like

Did you wire the plasma cutter to RAW voltage? Or are using divided voltage through cnc plug? Everlast plasma cutter work best wired to read Raw voltage.

So far through the dived voltage. Wasn’t too keen on the warranty voiding so I wanted to try it first.

Thanks for mentioning the tip on Raw vs DV, from what I read that is the way to go.

Also much thanks to everyone so far. Great community support.

I run an Everlast 82i. Its wired raw voltage and has never skipped a beat. I don’t believe you will void the warranty either. If Everlast would update their cnc board we would not have to do this. Just REMEMBER the work lead is the red wire. Torch is the black.
Just follow the instructions on Langmuirs site.


post flow needs to be running 30 seconds…this does not affect any cutting but it needs to be long to keep the tip[ cool…everlasts are known for warped heads if not cooled properly…


“Now the issue is the THC. it is reading a solid 0.0 volts now.”

Are you running on a laptop ?
Is the AC power connected ?
If so, try unplugging your laptop from the wall, and re-run the THC voltage test in FireControl.

I ran an Everlast 50S for the last year using RAW voltage and it (THC) worked without issue.

Wasn’t looking when the cutter was running. Everything seems to be good. Now its just tuning the settings.

If you can do a follow up and let everyone know what fixed your problem, that way others can learn if they have a similar problem