Pierce delay torch not firing (SOLVED)

okay so im getting pierce delay when I try to cut. program starts IHC sets up then torch moves before firing. Im using fire control latest version… It tells me the pierce time is too short. Tells me to go to my CAM software and set it to at least.5 s I cant find that in sheetcam. I have settings on the FC console but Ive tried to + to the time but it doesnt seem to do anything… feedback please? Thanks

Pierce delay is set in your Sheetcam tool.

1 Like

is set automatically or manually? i just dont see it if its in there

so i thought try to do the THC test and its not firing

so I noticed that my torch speed was set to 2450!! This was a free dowload off the internet… Then I reduced the speed by 75% and it worked but, when it completed the cut the torch wouldnt shut off even though the program box on the screen said complete. I had to kill the power on the machine… Dam!

crazy that the speed was so high… IDKW

There is a lot to unpack here. Is this a program that you downloaded from Fireshare as a “cut ready” file?

If the speed was 2450, it was probably a metric file that had the speed in millimeters per minute. 2450mm/m would be equal to 100 IPM. If this is a file that you post processed through Sheetcam, you need to change your units under application options,

The pierce delay in Sheetcam is in the tool settings. Just double click on the tool and there is a field for “pierce delay” right under the feed rate.

If the torch didn’t shut off at the end of the program, it was probably because your plasma cutter is set to 4t. It should always be in 2T mode for CNC cutting. The setting is circled in this picture. The cutter in the picture is in 4t mode. You want the top light to be on for 2T.


Thanks. I had it running back up to par last night. But a file I made from scratch. This was a free file from someone’s website. But no way it was traveling at 100ipm. It was moving crazy fast.

You should only run files that were post processed for Firecontrol. Files that you get from someone, other than a Langmuir table owner, will be problematic. Even if they work, they likely have commands that Firecontrol doesn’t know what to do with.


Ya I downloaded a file but I opened it in Inkscape saved in then ran it through sheetcam using my settings. But I don’t know what exactly happened.