Pierce delay issue

Issues with pierce delay. The cutter begins and then makes two cuts then stops after moving to the second number object and shops. Never fires, only touches the material, adjusts and then sends error message. I have uploaded

screens shots of settings as well as the error. Thank you in advance.

What pierce delay do you have set in this program?

1 Like

These are the settings. With my HYPERTHERM I need to add 5 seconds per manual however this is in percentages.

You didn’t provide any settings.

You simply provided a partial screenshot of firecontrol’s override function.

What is your actual pierce delay, entered in your CAM and incorporated into your G code?

Adjust it, rerun new code, and run the program with the new pierce delay.

No metal thickness (that you’re cutting on here) should require 5 seconds. You might be thinking 0.5, I find sometimes 0.5 is problematic with Fusion so my shortest pierce delay is 0.6 and I use it for 18, 16, and 14 gauge steel.

1 Like

That doesn’t tell us anything. What pierce delay number did you type into the tool setup when you were creating the cut file? Better yet, either upload the cut file here or open the file with a text editor like Notepad and copy and paste the first 20 lines of the code here.


Ok in SheetCam Original pierce delay was 0.5 sec, tried 0.6, 0.4, 0.8. Ran post processor after each change and saved. Then opened each one in Firecontrol. Experienced the same results.

(v1.6-sc) numbers code.txt (50.4 KB)

Another issue is the double cut on edge but I think I need to clean that up in Inkscape

PD should be at least .8 secs to have a consistent torch fire. there is an inherent delay from when FC commands the torch to fire till when it actually does and that almost .5 secs.

also what gauge are you cuttings? 225 ipm’s seems awfully fast.


Minimum pierce delay is going to be different depending on your plasma cutter. My Everlast works fine with .4 sec. on 14 & 16 ga.

I suspect that this may be an air supply issue instead of a pierce delay issue.

If it only worked on the first pierce, I would say it’s a delay issue. The first pierce delay is artificially long, so it will usually work even if your delay is too short.

Since it fires for the first two loops, it sounds like an air pressure drop is causing the failure to fire.


Running a steady !00 psi at 45 amps on cutter

Cut your air back to 65psi flow, 100 is way to much.


Regulator at 65 psi, pierce delay 0.8 sec, same error but this time with no firing of torch at all

As far as pierce delays I have run a rw45 and a ht65. From thin material up to 1/4 I have never gone over .6 delay. I cut some 25 ga. With a .4 no issues what do ever.

I agree with @ds690 sounds s lot like a air issue . Pressure can be there but not volume making the pressure drop quickly.

1 Like

If your plasma cutter did not fire the pilot arc at 65 psi you have a air or consumable problem.


I do not believe that to be issue. New consumbables and made a successful cut before with the 100 psi.

if volume isn’t the issue. what’s the chance air quality is trashing your consumables?

Could also be the clamp holding the torch is too tight or a bad swirl ring.

I just had a brand new swirl ring cause frequent miss fires even brand new OEM.

1 Like

This issue is 100% a plasma cutter/torch issue and not a Langmuir software or electronics issue.

Agree with David. If your Hypertherm is not giving you an error, try to increase the sampling time to give the cutter a chance to give an error.

Also agree with @nicaDd. Pierce Delay with Hypertherm 45XP @ 0.6 seconds works a majority of the time, @ 0.7 seconds nearly every time and @ 0.74 seconds every time.