Noob alert! Table keeps freezing in the same spot (solved)

Hello everyone! Long time reader, first time posting. So I’ve read through all of the forum posts and I can’t seem to find my specific issue. Im running

  • Crossfire Pro
  • Firecontrol
  • Macbook M1 16gb
  • Cut60 Plasma (the approved model)

I was able to cut lines just fine in FireControl to test the pierce height, cutting speed, etc. That all went well. After that I tried loading a couple ready to cut files from Fireshare and each and every time the projects stop in the same spot. The torch will also continue to fire, so I’ve had to manually shut it off several times, which is not ideal. Can confirm that air pressure is good, consumable is good, I just have no idea why it keeps stopping in the exact same spot in the tool path. I’ve uploaded the file im trying to test if anyone wants to take a look. Without fail, it stops at the bottom of the lightning bolt. I’ve tried with and without THC and it stops at the same point each time. It may also be worth adding that FireControl freezes as well, and the STOP and PAUSE keys are unresponsive. Any help would be greatly appreciated.
boltbolt-90 IPM, .6 (555 Bytes)

Sounds like EMI issues. Do you have a picture of your entire setup? It helps to know where your plasma cutter is in relation to the rest of the machine and how the cables are routed.

1 Like

Nothing jumps out at me with this g code.

You have some way of watching the incoming air pressure to see if it’s dropping off to that long of a cut.

Can you run a 20 inch long straight cut with no issues generating program in fire control?

Yes, here is a picture of my setup. I can stretch the cord to about 10 feet away from the plasma but it still reaches the laptop. Thank you for your quick response.

I was able to run several 12 inch line cuts just fine. I’m running a 60 gallon with 13 cfm so I at least mostly certain that it’s getting the air it needs. The air pressure has remained constant. Thanks for your reply!

I read about the EMI issues, and my laptop does have an aluminum housing. I’ve tried plugging it in as well to ground it but it didnt make a difference.

I don’t know if this has any value in this discussion but here it is:

1 Like

Thanks @ChelanJim

So, I got out my 10 year old Windows laptop and downloaded the compatibility version of FireControl and boom, it cut like butter. I won’t be able to run it on the Windows computer long term but at least we solved the problem. Looks like Mac compatibility is a ways off at the moment. Or I may be able to try one of the ferrite loops to block the EMI.

POS 10 year old Windows laptop - 1
Brand new top of the line Macbook - 0


Perhaps we should alert @langmuir-reilly that this can still be an issue out there for folks.


These commercials drove all the nails into Apple’s coffin for me.


I am running roughly the same Macbook. Is that the power supply for it in the picture? Does that have a ground prong? My apple factory one does not and it works fine plugged in but if it has a ground try running the computer off of batteries. Have you done a continuity test between your USB shell and the table? Also, a picture of the left side of your table setup would be helpful. Looking for cable management that leads to EMI. I’m feeling pretty confident that’s where your issues are.


This is a different issue. I was involved with this one while it was happening. The computer would not connect at all to the table.

I understand your point. Lots of variables still unanswered.

1 Like

Hey y’all, thanks for alerting me to this!

There are known compatibility issues with Mac devices equipped with Apple Silicon processors (colloquially M1/M2 chips). You can find more info in the PSA that @ChelanJim linked to previously.

Unfortunately, development tools and information about these processors has been slow to reach smaller software developers like us. We’re working on making FireControl run as consistently as possible on these devices, but unless Apple provides a way for smaller developers to gain access to the necessary tools and information for developing for these processors, there’s going to be some bumps along the way. Apologies!


@deadred What usb cable are you using? I run an intel MacBook on my table with no issues but have never tried my new MacBook with the M2 chip due to there being no USB and only USB-C port.

My experience with that was the M1 works fine, you were having trouble connecting to intel based Macs. His problem sounds like the old fashioned EMI issues not a connection issue.

1 Like

Hey Scott,

There are no known compatibility issues with Intel-based Mac devices.

The comment that I was tagged in was in regards to Mac compatibility, so I wanted to provide clarification in that regard. Apologies for any confusion!

1 Like

The connectivity issues for Intel based have been sorted out with recent releases. Thx

So my Macbook is the M1 silicon chip running Ventura 13.0. The wall plug in that it uses does not have a ground prong in it. The Mac only has USB-C connections so when i connect it to the tables USB I have to use a USB to USB-C adapter. Could that be where the problems coming from? If you need a better picture please let me know and I’ll get you what you need. The computer connects to it fine and I can send it commands, its just when I start to cut something complex and the plasma turns on that it doesn’t complete the tool path.

As far as the rest of my wires I have my divided voltage wire and the torch on/off wire coming down from the plasma there on top of the shelf and down to the box. and the rest I’ve attempted to tuck up underneath next to the control box. I took the panel off so the setup would be a little easier to discern. The plasma, table, and the compressor are all on their own individual dedicated circuits. Thank you all I really appreacite your input and help on these issues!

I’m using the one that came with the table but I had to attach a USB-C adapter to it so that I could use it with this Mac. I actually don’t mind using the old Windows computer but it’s just so slow that projects take a lot longer to load, etc. and it gets a little cumbersome after a while.