No manual torch fire, no relay click, new relay

Hi, I have a I have a new setup
CrossFire Pro w/THC
Razorwel 45xp
Firecontrol
Sheetcam TNG 6.0.30

I have everything set up and am trying to get the table running. This is all new to me, so I’m feeling a little out of my depth. Hoping the great support on here can help.

The problem I am experiencing is no manual torch fire. After some trouble shooting and reading on here, I realized that the relay wasn’t triggering and Langmuir customer support has sent me a new one. Received today. Still no fire and no relay click. Torch fires on the trigger.

I have
~read everything similar I can find here and elsewhere!
~switched and reset the relay ( a few times).
~switched the on/off and the RIGHT side is voltage divider cables
~checked continuity on the torch fire cable
~checked wiring hook up on the voltage divider box
~made sure torch fire LED at relay lights when manually trying to fire
~checked a reset THC control board and verified LED status

What am I missing? Is is it possible the replacement relay is also bad? Or is it something else?

-Derek

not sure if i missed it but have you tried to do a manual fire within firecontrol? you need to enable it first then the manual fire button is accessible.

Thanks for the reply nicaDd.

Yes, I have been trying to perform a manual fire in FireControl. It allows me to push the "manual torch fire " button, and shows that it is telling the controls to fire (LED near relay in electronic box lights, button changes to manual torch fire OFF), but the torch doesn’t actually fire.

And you don’t hear the relay click when you do that?

Strange that it’s doing that with both relays.

Right. No relay click with the old or the new relay. I was sure it was the relay, until the new one didn’t work. Now I’m just scratching my head until I can call Langmuir tomorrow and see what they say.

Yeah that’s strange… open another ticket with them… they respond better/faster that way instead of calling…

Did you try switching the CNC cables again after the relay swap? As you probably know, only some of the Cut 45s have the TORCH ON/OFF and DV ports backwards…

that wouldn’t cause the relay not to function though. he can’t even get that far doing a manual fire from within firecontrol.

Hi, thanks for sharing your thoughts. I have tried switching the ports-no joy.

I have also tried shorting across the wires at the torch fire cable points at each location (plug on cutter, end of cable, barrel on electronics enclosure, wires inside electronics enclosure, etc) and each enabled the torch to fire. Just nothing thru FireControl.

I’ve reached out to Langmuir, so I’ll let you know what I learn.

-Derek

I’m thinking, relay driver transistor on the board maybe. :nerd_face:

I haven’t heard back from tech support yet, but I’m thinking you may be correct.

I ran into the same issue when I first received mine. Went through their trouble shooting steps, received a new relay, and then found out the control board was bad. They sent me a new control board and I was on my way cutting! They will get you fixed and running.

im having the same problem now. no relay click. pretty bad timing as i need to have parts cut today

Langmuir has been great on this. They have helped me trouble shoot each step of the way. I should receive the new Motor Control Board tomorrow and I hope to be up and running soon.

The only issue is that it takes a day for each email reply and then a week to get the parts sent to me via USPS. So, while it progresses steadily, it takes time. I’m 2.5 weeks into troubleshooting on inital startup now.

1 Like

If you haven’t already, pull the cover off of our electronics unit and make sure the relay is seated correctly. You might get lucky and it will just be loose.

-Derek

Received the new motor control board today, installed it, and it did the trick. Made my first test cuts tonight!

1 Like

I had the same issue when I installed the THC kit on my original Crossfire. It was the controller board. The relay driver transistor was popping. I was using a torch that worked perfectly y with the original Crossfire. After the upgrade, it fired once during the final install checkup but then failed. Langmuir sent me a new board, the same thing happened! I started to suspect the torch, I ran some tests to see how much current it drew across the trigger circuit, when I pulled the trigger, my Fluke meter went off the scale and shut down. Not a good sign. I used a different cheapie DMM and saw it had a BIG spike when the trigger was pulled then settled down to a more normal voltage. Wasn’t much I could do about that. I decided to go big or go home and bought a Hypertherm 45 XP with a machine torch. Langmuier sent me another board. I didn’t want to blow it up again hence the new Hypertherm. Not a cheap fix but it sure took care of the issue! I did some component level troubleshooting one of the dead board. It was definately the relay driver transistor. They are really small little buggers, surface mounted of course. I was able to get a cheap switching transistor and replace it. This board works now too. Not sure it’s worth the hassle though, my eyes aren’t gettting any younger and even with cheaters and an Optivisor it was no fun replacing the blown transistor. This is a very difficult repair without a rework station. I wouldn’t have even tried it without it.