No communication between computer and controller - solved

Hey everyone, I’ve been trying to reach out to Langmuir for several days now and I can’t get anyone to get back to me, so I thought I would ask on here about these problems I’m having. This past thursday I used my mill to cut a project and on friday I turned everything on and the computer is not talking with the mill controller, so I can’t home the machine, move the gantry, nothing. Heres what I’ve tried so far. I made certain that all cables were plugged in and made sure that I have adequate 110 and 240 power coming out of the wall, got nothing. Then I changed out the USB cable that is used to talk to the controller and still nothing. I then uninstalled cut control of the PC that I purchased with the unit and re-installed it. still nothing. I then got my Mac, downloaded cut control onto it, to remove the PC from the variable, hooked up the Mac to the controller, and nothing. I then went to inspect the controller by opening the cover and making sure that all the wires were connected properly to the components and they were fine. I then checked the fuse and used my multi meter to confirm that I had power from the wall threw the switches as well as the emergency shut off and that’s all fine. I have green lights on all the components that are in the controller, so I’m assuming all that is working. MY theory is that the circuit board that the USB connects to might be bad, or some possibility that two brand new USB cables that I tried are bad. Anyone else have this issue, or have an idea what I should do next?

Open up control box and see if the usb control board has led lights lit.
Get a volt meter and on the upper left you will see a plug that says 36v. I believe that its a black wire. Check that wire to the wire labeled common. You should have 36v dc.
If you have correct voltage and have no leds lit. The board is bad. They will send you a replacement.

1 Like

There are no LEDS lit on that board, I wasnt sure if there were any on there or not, but I’ll check, thanks.

On the right side in the middle of the board.
Two small leds.

Are you sure the emergency stop isn’t pressed. I had this issue and it was because it was pressed. It kills power to the control board that connects to the pc USB. As the other poster said there should be a lit LED on that board.

Well I checked the USB board, I do not have power coming into the USB board, I did re-check and confirmed that I have main power going to everything. The cable that gives power to the USB board comes from what I assume is an inverter? Not exactly sure about that, but it is on and the digital read out has a Zero on it.

The first time I booted up the machine, it had no communication, I removed the USB isolator, and everything works fine now, hope it doesn’t bite me later.

@nucliwelder If you have anything like the tool setter or probe plugged in, I would unplug these just for troubleshooting purposes. Next, if you have a digital voltmeter I would check the DC voltage at the board connectors between 36V+ and COM to make sure you are seeing voltage into the control board. Another thing to try quickly would be plugging the USB cable in without the USB isolator (if you are using our control PC).

1 Like

Okay, I just unplugged the tool setter and the probe, re-checked for power at the USB control board and there is 36V at that connector, but I still don’t have any LED’s lit on the board and still no connection of the computer and controller.

OK thanks! I’ve instructed Jake our support engineer to contact you and get a new control board sent out. Sorry for inconvenience!

1 Like

Good evening everyone, just an update if anyone cares, I received the new USB board and got it in the Mill and it now moves and operates like its supposed too. I don’t see anything on the board that looks bad, so I have no clue what happened to it. Thanks for all the help.