Mechanical/Electrical issues when running the machine

Hello, wanted to see if anyone may have some insight on this. When I perform a “send to front” move immediately after homing I get a loud jolt/jerk noise/stutter where the vibration can be felt outside of the machine. I thought that maybe something was hung up on the rails, but I can rapid the Y-axis from the home position no problem. I can also do the same with the x-axis, but when ever I perform the “send to front” immediately after homing I get this jerk. (see video)

One of your steppers is skipping a step. A few things could cause that. One being yaxis rails out of alignment second being the ball screws are at different pitches and are not a matched pair.


Are you able to jog back and forth through the entire extent of the Y axis rails after it makes the ‘pop’ sound. Or does it ‘pop’ intermittently when jogging in the Y axis.

1 Like

Hello. Yes, after it makes the pop I’m able to jog in both the Y and X axis without a problem. I first thought that it might be a green cap sticking up on the rail, but I checked and the rail is clear.

I had this exact issue, but it did it not only on send to front, but 100 IPM jogging as well while going forward and back.

It took me a while, but I finally traced the issue to the Y1 ball screw (in my case). There seemed to be some binding going on. I loosened the front ball screw bearing mount and jogged the machine forward and back with no issue. Tightened it back up and the issue returned.

After going through countless combinations of gantry positions and loosening and tightening of both the bearing mount and the stepper motor mount, I finally resolved it by loosening both mounts and re-tightening with the gantry all the way forward.

This is what worked for me on my machine. You may have a similar issue. I was thinking at the time that the next step would have been to loosen and re-tighten the ball nut clamp in the Y1 carriage, but you need to remove the gantry for that so I was trying everything possible to avoid that of course.


Thank you for the reply and good insight. I’m waiting to see if LS has any suggestions, but will give this a try If I don’t hear anything back. Thank you again.

After reviewing your video, and the fact that this is happening at the back where the switches are during the auto-squaring process leads us to believe that this is due to gantry squareness. When we set the limit switch stops after squaring the gantry, the gantry needs to be completely relaxed when re-tightening the bolts. It’s also critical that the limit switch stops trigger within 0.001" of each other. The gantry is so stiff that even just 0.005" of out of square can cause the gantry to bind. I would highly recommend re-doing the gantry squaring procedure part of the manual; if done right it should solve your issue immediately. We had another customer with this exact same issue and this is what turned out being the cause and fix. Good luck!


Great, thanks. Yes I will give this a try. I’ve had an issue with my limit switch and the replacement LS sent should arrive this week. I’ll plan on making the adjustments once it arrives. Thanks again.

** SD card not showing up on mini computer**
Hello, is anyone else having problems getting their SD card to read using the Mini PC? I’ve used up all the usb ports and figured that I would be able to use the SD card slot to transfer the NC files to the MR-1… No go. I doesn’t even show up. I’ve looked at the device manager for solution, but nothing. Also, I can’t get the Mini PC to show up on my network so that I can transfer files over the network. Any thoughts?

My little sd card in the reader.

I had this problem, just go force windows updates to run on it a few times and do some reboots. It seems like it struggled (or was too slow for my taste) to do all the updates. Once I got through a few of those, it was a much happier little machine. As for having it on your network, my default state is disconnected from network as I am not really looking to properly secure the machine :slight_smile:

1 Like

Thanks so much for the feedback. I really appreciate it. Did you update your mini pc to windows 11? Mine is asking me that as I run windows update.

Z axis doesn’t change speed between 50 and Rapid
Has anyone else noticed that the Z-axis doesn’t change speed when switching from 50 to 75 to Rapid? Is this on purpose? It just seemed odd that I can audibly hear the difference on the Y-axis when switching through the rates, but not on the Z.

Yes - I believe it is limited around 40 IPM if I recall. Such a relatively short travel that there is little benefit of going faster. I had to drop my max speed down to avoid missing steps and found no change until I got down below 40.


Okay, yeah that makes sense now. Thanks for the insight.

You also say you can get to Windows update so I assume you are on the network. If you aren’t used to it setting of file sharing on Windows it can be rather complicated. I recommend folks use Microsoft One Drive or Google Drive. Benefits you that all your machines stay in sync so the shop CNC machine gets synced with whatever machine you do design in and also have a copy offline in the cloud if a tornado/hurricane/wildfire wipes you out.