Machine torch mount loose

Is it normal to have side to side movement with the machine torch holder it seems to be 1/16 of travel. I tried the hand torch mount and it has the same play. Don’t know if I am missing somthing or if this is considered normal. I have cut a few signs on 16g. There is some bevel but I am nowhere near dialed in with my settings. My very first cut on the machine was a 1’ plate, straight cut, for my hyd press and that came out really good. It had some bevel but I wouldn’t expect that thick steel to perfect and I didn’t notice the mount movement until recently so didn’t think twice to check if the cant of the torch coincided with the bevel.

Running pro table, Thc, hypertherm 45xp.

Are you sure its the torch mount and not the eccentric bearings on the Z axis that need adjustment?


Good answer.

I question I get a lot is, I just installed the cnc torch I got from you now I am getting bevel on my cuts. First thing I ask them have they adjusted the bearings on the THC mount. Most of the times they didn’t even know that they were adjustable or how to do it.


That was the first thing I checked but I am sure the movement is from the slot where the torch mount slides in. I can actually see it when I move the holder with my hand.

can you get a better picture

When I get home I will snap a pic of the gap between the slot and holder.

Ok I hope these links work. Never posted a video before so here goes.

What’s keeping those capscrews on the red torch mount from getting tight? I can’t tell if you have the same washer set up as this drawing but you have a cap screw where they show a thumbscrew. SHouldn’t matter but it seems like it should get tight.

The thumb screw will not work with the machine torch. I believe that a cap screw came in the kit with the langmuir machine torch mount. It doesn’t matter how tight, within reason before the torch mount strap bends from too much pressure, I still get movement. To me it appears that the tolerance is too lose on the z axis slot. I tried the hand torch mount as well, same results. I

I put another machine screw in place of the thumb and cranked down them down, bending the strap till there was no movement.

1 Like

Well I cranked it down and that stopped the movement. I guess my theory was if I were using the thumb stud there would be no way I could bend that strap or get it tight enough without using a pliers or something and I didn’t want to take my day out on the screw and bust something. Thanks for your help.

I never ended up doing it yet but I thought about cutting a different shaped thicker strap to replace the original.

Glad it worked out for you. I guess there is a chance something could have busted. It did work for me too

Makes sense regarding the thumbscrew. Looks like it would hit the machine torch. Does seem wide that it won’t tighten down. But it sounds like others have had the same issue. Thanks!

I agree with that idea thicker strap may be the key.

Someone could even contact cement on a thin little piece of rubber so it’s a little more grippy you don’t have to crank down as hard.

1 Like

You could 3d print one of these and not have any movement.


A 3D printer is next on my list. Maybe this winter. Planting season is around the corner so I barley have time to focus on my plasma table right now :slight_smile: .

1 Like

That is a nice mount for sure.

I preordered the new pursa XL so I’m waiting for delivered before I have any 3D printing capabilities.

Doesn’t it seem strange that the machine torch mount bought from Langmuir doesn’t fit? Is it just me? @langmuir-daniel


Nice that is the one I have looked at as well. I almost bought the mk3 but held off since hearing about the XL.