Mach3 Hangs once Torch is Fired

I’ve seen a few posts on this topic but no solutions.
In my case if I allow Mach3 to execute a file Crossfire moves accordingly. Razor 45 Fires and Mach3 hangs. Torch goes off and air is continuous until I disconnect Computer Switch cable (likely caused by program hang). Then I disconnect USB cable and reconnect and Mach3 returns operational. I can toggle RESET and move crossfire in X-Y. Also tried everything on another computer same results.
Next I tried to manually fire the torch. Executed the cutting G file, crossfire begins to move then I manually fire the torch and cut a bit. Sometimes I can cut an inch before program hangs and sometimes program hangs right after torch fires.

Also note I just purchased and assembled my CrossFire, so just starting out and can’t get passed initial torch firing.

Recommendations and solutions greatly appreciated.


you might have the issue with the relay. There was a post about it what daniel put out.

I submitted a message to Support after I summarized the USB connection was being corrupted. The emissions from Arc is causing noise induced on cable to computer. Support is sending me another USB cable with Chokes on the wire. I tried a few I had in my shop and had success. This lead to my next issue with torch out, that you so kindly answered.