Losing THC with 3rd gen Cut60, divided voltage

Crossfire pro and Cut 60 are roughly 6 months old. Cut 60 wired divided through cpc port. I had an issue several months ago, where I noticed my cut quality going to crap. Finally realized that my THC was not working at all…no indicators for up/down/active on Firecontrol, and no z axis movement. Tried Smart and Live voltage, same issue. Through talking it over with LS and troubleshooting down to the control board, I removed the THC chip/reseated, and it worked perfect after that.

Fast forward a couple months and I just had the same issue again…I should have left the problem alone, but after verifying THC input voltage to the control (walking through this with LS customer support) I removed the THC chip and reinstalled again.

So LS support made a comment that has me wondering about my issue…they said that they have seen voltage spikes sometimes from Cut60’s wired divided that may “saturate” the THC chip and cause issues. I have the latest gen Cut 60 and while my voltage readings were very stable, I could’nt rule out a voltage spike at some point.

Would someone be able to offer insight to if this sounds reasonable…then I’ll just wire it up Raw.

yes I’ve seen a couple of people having problems with divided voltage go to RAW voltage with the newest cut60 due to POSSIBLE voltage spikes. I believe @Kwikfab had that issue and wired his for RAW voltage. The VIM box uses a separate circuit for RAW voltage so it’s still usable.

I wrote an installation guide for wiring it to RAW voltage if you want to go that route.



Have you verified that your VIM is good? As mentioned, the VIM has two circuits as one is for DIVIDED and the other is for RAW.

I run a CUT60 (owned it for +2 years), and had it running DIVIDED for approximately 8-9 months without issue. Then suddenly I had an odd warning about pierce delay/THC on Firecontrol. Happened once.

Then it happened again days later.

Followed some partial troubleshooting myself and I came here to ask if the DIVIDED circuit in the VIM is one that can be tested for continuity (without voltage running through it). If you probe each end and get no continuity, then your vim is bad on your DIVIDED side.

I switched to RAW and will keep it that way.

Be advised

Langmuir states not to open your vim, as there’s no real need to do so. I only did cause I had confirmed it was bad and got a new one sent -

There’s a write-up lingering around that’s super easy to follow and I used that for tapping for raw voltage -

Not being a fan of wires sticking out, I opted to modify my setup a week later -

Just food for thought if you wish to go that route -

If/when I need to pull my plasma cutter off my table, I didn’t want to worry about hanging cables -

Look ma, no wires!

1 Like

There’s a write-up lingering around that’s super easy to follow

That was my write up :upside_down_face:

1 Like

Should post it! I only found it cause a member provided it via FB messenger. Otherwise I would’ve had to do a search to look for it or just dig into my plasma cutter myself.

@cyoung If you’re detail oriented like I am (or OCD), you may as well just request a replacement CPC plug for your CUT60. I didn’t like having a barrel plug hanging (unused) for my DIVIDED voltage since I went RAW.

Here’s the write up. it’s floating around other threads as well.

PrimeWeld Raw Voltage Cable Installation.pdf (2.3 MB)


With this being only the second time this has happened (and its working right now) I am assuming the continuity test would only be valid in error state? I have verified all voltages in/out of the vim and they are within spec (again, when system is functioning properly.)
This is a pretty easy change over and I love the detailed write up…so I will be switching it over when I take the machine down to weld my pan together (which I should have done initally as well!)

Hook it up to Raw voltage.


On the cut 60 I agree they should all be wired to RAW voltage like everlast machines. I initially had mine wired to the divided voltage but felt like I was playing Russian roulette… Mine was probably one of the last gen 2 machines. It had shipped, but I hadn’t received it yet when it was announced on here, that there was a new more table friendly machine coming. I called them to see if I could trade it for a newer one, as I would be using it on a Langmuir table. He asked me to try it first and said the only change was moving the port and adding some insulation. Nothing about any change to the divided voltage board. All that to say… I believe the recommendation should still be to connect to the RAW voltage inside the machine. I am still actively looking into replacing it with a hypertherm or a everlast. I probably should do it before we start to build in the spring, while I still have some money in my pocket. :stuck_out_tongue_winking_eye::joy:

it’s weird that its hit and miss for some people and not others. right now i have 3 cut60’s. the original one i bought in 2019 ( I guess you would call that a gen 2) and a pre-released gen 3 with cnc port on upper right Primeweld sent me to test for them before they pushed it out to fix the original issues with the cnc port AND crazycaseys cut60. They sent it to me to test as well after all the issues he was having with it.

ALL 3 have been working fine with divided voltage cnc port. even casey’s. I’ve Been running that one for a few months now with no issues.

the one i did the RAW voltage write-up on was the pre-release and have never even used the RAW voltage side of it yet.

But i would agree at this point to anyone who’s having any kind of remote issues with their cut60 to wire it for RAW voltage from the lugs inside.


So Casey’s issue ended up being the Langmuir control board right?

I believe that to be true. I don’t know which one, but the new control box fixed his problems. I believe

1 Like

Yes… it was pretty ruled out that it was the cutter but he also has concerns about the white “block” inside the cutter having burns marks, so Dustin from prime weld sent me the cutter once Casey sent it back to them.

I checked all 3 cutters and they all have burn marks on that white block… it’s some kinda of ceramic coating incasing a resistor of some sort so it’s doing it job by dissipating the heat.