Limit switches stuck open (Solved)

I updated the firmware on my machine this morning and i am now receiving a “check limit switches” alert when trying to home the machine. My Y2/Z limit switch(es) are stuck open. I powered the machine off, replaced Y2 and Z axis limit switch and i am still receiving the same error code. Has anybody experienced this before?

Also i have checked all wiring and made sure everything is still plugged in properly to the correct location. We have not done anything with the machine. Ran perfectly fine last week.

Update the firmware again. Are you running 24.1? I never update the firmware unless Langmuir tells me to.

1 Like

I was on the 23.1.1 beta release for the longest time. Just rewired everything. Updated to 24.1.1 worked for one 4 hour operation. Shut the machine off and went home. Came in the next morning, started machine up. Same thing. Back to Y2/Z limit switches stuck open. Sent a tech request to langmuir but still have not heard anything back for 2 days.

Are you sure that both switches are working? Not depressed should be closed.

Yes, I even swapped the switches out with the spare switches I had on Y2 and Z

Have you tried to delete 24.1 and reload 23.1 yet?
Maybe you have a corrupt file on it.
If you have a new V2 probe, you must get 24.1 again.
I’m just throwing stuff up there. I’m sure Langmuir will handle this soon. The whole holiday week and the Titan launch probably got them strung out.
Are the individual switches being acknowledged on CutControl icons at the bottom of the screen?

Issue fixed! Finally lol

1 Like

Well, what was it? No secrets here :grin:

:rofl: corroded wiring will get you every time!


Glad your up and running. Thanks for the update.

1 Like