Limit switches open? (not letting me home the machine)(SOLVED-cables got switched)

I installed the limit switches a few weeks ago and everything was running fine in terms of gantry motion (machine was homing, I could manually control motion, etc.).

I started the machine again this week and I got a pop-up telling me “The machine controller is showing that your Y1 Y2/Z limit switches are open. You will not be able to home your machine until this issue is fixed.”

None of the limit switches (x,y,or z) were depressed at this time (depressed = “closed,” I assume). When looking at the limit switch indicators within cut control, it indicated that the Y1 and Y2/Z limit switches were depressed (see image) and it did not indicate that the X limit switch was not depressed.


  • Manually depressing each of the limit switches (X, Y1, and Y2) did not result in any of the UI indicators changing, including the X indicator.
  • The emergency stop was not activated
  • The machine would not let me manually jog the spindle in X, Y, or Z direction
  • I read this post but I don’t think that solution would work because the limit switches don’t seem to be working at all. Limit switch open

With the LS limit switches (I hope it’s universal across their product lines) OPEN is how the switch tells the system that it has been depressed.

This also means that if one of them is unplugged, it’s open.

If a wire gets damaged (pinched, cut) it’s open.

If a switch get’s debris in it and binds up the mechanics inside, it’s open.

I don’t know how the wiring is on the MR1, but try disconnecting each limit switch, and short the terminals in the plug to see if the control sees the change. If yes, then the limit switch is the problem. If no, keep going.

If not, then disconnect them at the control box and short the terminals and see if that makes a change. If yes, your wire is damaged somewhere or the connection is bad. If no, it’s in the control system.


Problem solved, thanks!

Well, what was the problem? This is valuable information for future MR1 users.

1 Like

My problem was so unusual I thought it wouldn’t be helpful for future users. I accidentally had the limit switch and Z motor cord swapped, so the program was misinterpreting signals relating to the Z-axis gantry motor as an indication of a limit switch being open.

Last week I had unplugged and re-plugged those cords, but didn’t realize I had swapped them.


Thanks for letting us know. By the way welcome to the family.

Very far from the truth. All of us think that we remember where every cable goes by heart on all of our machines. I have come to realize that with little helpers in the shop, sometimes a cable or two become unplugged.

I have been encouraging people, once their machine is set up properly, label both ends of the cable so you know where they go. It does take some extra time but believe me, you will get the time back the first time you question where a cable goes.

I am glad you reported back because BigDaddy is not to be trifled with. It has been told that he stands 3 feet taller than the average man and has roots that go back to BigFoot. Limit switch topics make him go crazy anyway so this might have been a “Hulk” moment…avoided. There again, I may have my superheroes confused. Have a nice day!