IHS fail the torch did not reach material within programmed travel

Hello, I’m very new to the cnc game and not too tech savy, I have a crossfire pro (not the OG one) and I use fusion 360 for cad, I have my file set up and ready to go, whenever I do a dry run everything works fine but as soon as I enable the torch and run the program it jogs to the first cut point then just drives into the material and gives the IHS fail, the torch did not reach material within programmed travel code. I am lost at this point. I have a picture of the g code if anyone can tell me what that means

That green IHS light in Firecontrol means that the IHS circuit is open. It needs to be closed unless the torch is in contact with the metal.

Jog the Z axis up and see if the IHS light turns gray.

If the IHS light stays green, there is a wire disconnected in the IHS circuit or the switch is stuck open.

The programmed travel for the IHS cycles is 5" down or until the IHS switch opens. Your Z axis motor coupler could be slipping or your torch is mounted too high and the Z carriage is bottoming it before the torch touches the metal.


Welcome to the forum.

In most cases this happens when the torch is mounted too high.

  1. Send a photo of how your torch is mounted.
  2. Manually move the torch down with the -z control in FireControl. You should be able to put the torch just below the top of the slats. If not, mount torch so you can.
  3. Or there is binding of the cables/travel of the z axis.

Sorry - David is on the right track. Disregard everything in my message after “welcome to the forum.” my message. :grimacing:


The IHS light was only green when the torch was hard into the material


Test the IHS switch operation by lifting up on the torch. It should open when you lift it and turn the IHS light green. It should go off again when you let the torch fall.

Jog the Z axis up and down and make sure the movement is smooth and the carriage is not hanging up.

1 Like

When I lift up on the torch the light comes on and when I let go it goes off, I checked almost every possible trouble shooting methods I’ve seen on this forum and still can’t seem to get it to work. I tried running a new program too and it did the same thing

I did however run the test on the THC and it had higher than expected voltage, would that have anything to do with it or is that separate

The THC should not have anything to do with an ihs fail error.

You should have enough posts to be able to post a picture of how your torch is mounted. That may provide a clue.

1 Like

Seems like when I manually pick up on the torch it turns the IHS light steady green but it kind of clicks before it does that and when I jog the torch to the material the light will blink

When you lift up on it, it open the IHS switch. That’s the click that you hear.

I suspect that the motor coupler is slipping as soon as there is resistance from the torch hitting the metal and that’s causing the switch to open and close momentarily.

Check the 4 bolts on the coupler circled.

1 Like

I’ll give that a try I also had what seemed to be superglue in the spring for the switch that seems like it was blocking it from fully compressing

Update tightened the screws still not working, I ended up unplugging the THC and it cut perfectly