IHS Constantly Erroring

Has anyone been getting IHS errors constantly? No matter how much slack (or little, tried both ways) I give the torch, I get them constantly. I’ve tried all sorts a different things to avoid it.

I read through the troubleshooting in the assembly guides but nothing seems to help.

Langmuir contacted me directly to help troubleshoot. Fantastic company to work with!

Ok so we were able to reproduce the exact issue that you are facing.

The way the IHS sequence works is as follows:

  1. The torch moves downward toward the plate over the pierce point. During this down move, FireControl monitors the IHS switch so that it can stop motion once the torch hits the plate and the swtich opens.
  2. Since the torch drives down to the plate at pretty decent speed, the torch has to begin its deceleration after the switch is open. The faster the down speed, the longer it takes. The longer it takes, the larger the gap between the switch contacts.
  3. After FireControl sees the switch open, it commands the torch to drive up .200". During this motion the switch closes and the torch lifts off the plate a slight amount.
  4. Next, the torch moves down to the plate again at an extremely slow rate. This slow rate is important in order to make the deceleration move after the switch opens basically negligible. Once the switch opens again, it sets the current Z position as Z zero.

Here’s the issue that you were encountering. Since you used pretty high torch down speed, it required MORE than .200" to slow the torch down. Therefore, when it made the up move of .200" it was not enough to close the switch. Since FireControl didn’t sense a switch closure, it threw the alarm you saw. We tested this on our machine here and got the IHS error you got.

Now heres the good news, all you need to do is slow your down speed to 100 IPM or less and the issue will be gone. Nevertheless, we are going to update the post so that the up travel is more than .200".


New versions of both posts have been listed on the downloads page!


That’s damn fast support. Cheers all around.


Is it possible to get email notifications when new posts, or otherwise other software updates, are made available? I wouldn’t have noticed the new post processor unless I was viewing these forums.

@noboost4you As far as the assembly manual, software guides, and post processors go it’s likely in the next week that these will be updated based on feedback from the first customers that start cutting. All of these items are constantly updated on our website so we suggest when you get ready to start cutting with your machine that you pull the most up to date material. After the first few weeks, these items are much less likely to change.

As for FireControl, it’s much more critical that we have a means to reach customers when updates are available to fix bugs, but also when we release new features to the software (which we definitely plan to do!). As a result, FireControl has a built in auto-updater which checks the latest version number on our server and displays an ‘UPDATE AVAILABLE’ button to alert the user that a new version is available. If the laptop that you are running is offline, we suggest periodically connecting it to the internet to check for updates otherwise you can visit our website which will also have a version history log. Hope this helps!

1 Like

How did you end up fixing this. I have had the crossfire pro Since July 2021. And it keeps reading out ihs error not enough slack. I’m ready to trash this machine!!!

If you keep getting the IHS error, it is probably related to how high the torch mount is in the Z-axis carriage. The Z-axis needs to be able to continue to move downward after the torch contacts the material, so it can unload and open the IHS switch. If your torch mount is clamped too high in the carriage, it will run out of travel before it can unload and trip the switch. Try loosening the clamp and lowering the torch mount about 1/2" and see if that helps.

It should look like this

1 Like