High power drivers

Any reasoning or just an answer?

just wondering.

Told me no dip switch adjusting required. These are the same motors and controllers they have used on the XR platform for years.

1 Like

So when they come out with the 200ipm kit is that a motor upgrade or drivers or both?

Don’t have that answer for you.

From what I’ve read in another post its just the drivers, but its not 100% clear. see post below towards the bottom.


I’m pretty sure they mentioned different pitch ball screws also…


@Bigdaddy2166 , I think I am missing steps at high rapids on Y and was thinking on upgrading stepper motors and drivers like you did. The question is will the driver upgrade be enough or should I upgrade to bigger motors like X and Z? Did you notice really a big improvement with only the drivers?

1 Like

No is the short answer. My stalling problem has disappeared though. I don’t believe they were a waste of money. I rarely take heavy MRR cuts on steel though. I rather watch it for an additional 5 min than excessively load the spindle.

1 Like

Did you also change the stepper motors on the Y axis or left them original and just upgraded to bigger drivers?

Just the drivers.

1 Like

You shouldn’t be missing steps every on the y axis with the standard drivers. Can you send a video to support? There’s likely another cause.

1 Like

Hi Daniel,

I have already sent support a video 2 days ago. If you can push them to take a look, that would help me get going. Thanks

Thanks, I’ll ping the support engineer about it

I was having trouble with my z-axis missing steps. I measured the actual current and the small stepper drivers only deliver 1.5A. They are suppose to deliver 3.5A, so I’m wondering if somehow some chinese knock-offs made there way in there.

Anyway, I replaced the z-axis driver with a $15 TB6600 based driver I and it delivers 3A no problem. Later I plan to replace the y drivers as well but I might not run them all the way to 3A, since the idle power usage will go up 4x and no need to run them that hot.

1 Like

This gave me 2x the torque for the z-axis and I have not missed any steps so far

1 Like

let me know when you upgrade the Y drivers as well. I had a couple of spare new DM860T from Stepper online that I tried to replace the existing Y drivers, but they failed to work. I tried different switch settings, but nothing I tried was able to run the motors. The funny thing is that the driver showed no alarm and they were powered, but no pulse to the motors. Not sure what was the reason, so I swapped back the old one and all was working. But still planning to replace them with better one, but dont want to spend $99 for the high power one that langmuir sells. I need to find the exact same replacement in amazon to save some money. THese DM860T have way more settings that required. I am now looking at DM860I or DM860H, but not sure which one will be the clone of the langmuir one.

Those DM860T drivers really should work unless wired wrong. I had a quick look at the data sheet, the only reason why I don’t think they would work if the jumper settings inside is incorrect. Documentation shows that internal jumper J1 should be shorted and J2 and J3 should be open. The only other thing I can think of is the input voltage may be a little too low since it requires at least 36V according to the datasheet, but I don’t think this is a problem.

I will let you know when I upgrade, but I have other issues I have to deal with first.

1 Like

I triple checked the wiring and I am sure they were correct. I did not mess up with the internal jumper though. I felt like the unit were disabled for some reason, even though the Ena input were disconnected which means enabled by default. Not sure what was the issue. Anyway I returned them.

you have links to this driver?