Help, torch not firing (solved to tight clamping)

Hi, been trying to setup my machine and have been running into a couple of issues. How do i wire it up, i thought i was following the diagrams but it doesn’t seem to fire the torch up. Can anyone please have a look at the pic and let me know what goes where. I am trying to follow the RazorCut 45 CNC Diagram. Does the pin 3 and 4 cable go to the CNC and 5 and 6 go to the THC box.

Is that a Razorweld that you got from Langmuir? It should have ports on the front of the machine and cables with aviation style connectors that plug into those ports for torch firing and divided voltage.

All good, got it sorted

could you elaborate on what it was…then we can lable the thread solved…

I have been trying to set it up and my torch still didn’t fire, replaced the torch to one with a trigger and that worked so wondered if it was the wiring. After a while i found out that if you tighten the clamp too much the torch doesn’t fire, now i am all up and going. Thanks

Was this a hand or machine torch?

If its a machine torch follow @mechanic416 machine torch mounting guide linked below.

Sorry for the late reply but i had to go to work, something about money and stuff. Yes it is a machine torch.

1 Like