Help, torch not firing. everlast 82i with thc

Hello, new user here, just recently received my first table, crossfire pro with THC. I am using an Everlast 82i. I set it all up about a week ago, however z axis stepper was bad and had to wait on a replacement. It finally showed up today and now all axis work as they should. Ive ran the break in procedure as per Langmuir’s instructions and did a THC test and it said everything is operating normally. I loaded a random program from fireshare, input custom settings such as cutting speed and pierce delay, 35 secs and 1sec respectively. It made the first cut no problem, however when i went to cut another piece, torch would not fire. Checked all the wires on the vim and to the electronics module and all were plugged in. I should mention that I am using raw voltage. I have the torch trigger wires connected to pins 1 and 2 in the cnc port connector, and the red and black THC wires connected directly to the lugs of the ground clamp and torch lead inside plasma cutter.

While not cutting, it displays live voltage as 0.0. I ran the thc test again, and this time torch wouldnt fire. I could manually fire torch using actual torch trigger and i get a live voltage of around 123. Every time i try to run the program, a popup tells me that if my arc never starts at the beginning of the cut, then my delay is off. Ive tried .7sec delay, 1 second delay, adjusted delay in firecontrol to 150%, 200%, and 300% which equated to several seconds before the z axis began lowering to the workpiece, and it still did not fire. I alsol tried decreasing delay and still same result.

What am I missing or doing wrong here? what can i Check? Thanks for any responses in advance.

Where is your torch bolted to the THC. Make sure its not on the lower part of the torch.
If the Internal plunger is stuck it won’t fire.

Well I just went back to the table and now it’s cutting again. Made 4 sample cuts in a row. Not sure what the problem is/was. My hand torch is clamped in the torch mount on the insulator ring

@Sapper1371 sometimes with the hand torch set up as you move the torch around on the table the pull of the torch cable will rotate the torch just enough to cause the retaining cup connectors to lose contact. if this occurs again you might consider rotating the the tail end of your torch slightly and see if that cause it to work properly.