****HELP**** Stepper motor play (SOLVED)

New machine. Was from the first or second group of machines when they first came out. Just setting it up now I jogged the x and y. Then parked it while I added the little board for the THC. I jogged the y and I could see one side binding. Upon touching the screws I can move one of the y axis stepper motor with my hand. The other does not move. The x does not move. Can anyone shed light on what may be the problem?

Are you saying this is a brand new assembly?

Perhaps there is binding at the lead nut. Maybe there is debris in the threads. See if you can access and blow out with air. Otherwise, you may need to disassemble and visually inspect. The lead nut is made of a nylon/Delrin type material.

You could verify if it is the lead nut by disconnecting the shaft from the motor and see if it turns.

If the stepper motor does not have holding torque, check the connection at the control box. If that is ok, swap it to the other Y axis port and see if the problem follows the motor or the stepper driver.

If it still doesn’t have holding torque when connected to the other Y axis port, it’s probably a bad motor.

If it works on that port, check the dip switches on the suspect stepper motor driver. Make sure they match the switch settings on the working driver.

1 Like

Thanks. What I found out is I thing the pins on the serial end of the cable were not connecting well. I could hear faint arcing when I touched the connector. It is now working.


It is new. I have had it a while and just setting it up now. Problem I found was in the serial end of the cable. Pins do not appear to be connecting well. Working now. Thanks

1 Like

its a known issue that the screws on the connectors are a lil too long so when you go and tighten them down, they back out the connector from the port causing resistance and arcing. You can either grind the ends down a little or just press fit the connectors into the ports. they are pretty snug.