Help! I'm about to send it back and ask for a refund!

We received our crossfire cnc table bundle that came with the water table and razorweld razorcut 45 plasma cutter. I’m about to send it ALL back! I’m using a HP laptop with Windows 10. Followed set up instructions and downloaded software required and got it to run the break in program.

I hooked up the plasma cutter, connected the long cable as directed and tested it by toggling the manual torch on and NOTHING! Went through all the instructions again, EVEN unistalled and re-installed firecontrol software. The torch fire cable instructions came with 2 cables a long and short cable (short one is for mach3 program, the long is for firecontrol program) instruction said to connect the long cable for firecontrol to the right sided port in front of the plasma cutter. I switched the long cable to the left port and tried a manual torch fire in the firecontrol program and it arched just for a second and turned off but air continued to run. So I received a plasma cutter that’s suppose to be a plug and play (yeah right! The ports are backwards according to the instructions).

All the YouTube videos for the crossfire are using the Mach3 software and the crossfire pro are using firecontrol software. Am I using the wrong software for my table and cutter?? Any help or advice would be greatly appreciated!

please do not be too frustrated…not everything is perfect plug and play…

there are a lot of people here ,including Langmuir people…who will help you through the learning and setup.

Youtube is not always up to date…

so the software for the crossfire pro is Fire control…
I do not know much about the Razor setup…but a lot of people will be dropping in who do…

my first question is what software are you suing to design…and what software are you using for post processing?

hold tight…it will work out

You should at least include @langmuirsystems in your post. They will know what system you have and how to help you.

Make sure your plasma cutter is in 2T. The arc will only last for about 3 seconds then go out unless your cutting metal, that is what is the pilot arc.

1 Like

Thank you for your response! I don’t have the pro, and I downloaded the auto fashion 360.

ok…standard Crossfire…

I have years of AutoCAD experiance and I did not like using fusion360…it is great for 3D design but can be very hard to learn all the tricks to it.
Most people are using a more basic drawing tool…and then a separate post processor…
Inkscape for basic design is what I sue to a lot of my work…but I also still use AutoCAD for special parts.
then I use Sheetcam to process the designs into G-code for Fire Control.

I am putting this down as some people get very frustrated at the start with even just the programming.

I am just trying to help you not get frustrated…


I appreciate it! Is sheet cam available for download on the langmuir system page?

You get the download from SheetCam’s website. Langmuir arranges for the license to be emailed to you from SheetCam. Note that this usually happens on a Business day so don’t expect instant turn around.

Thank you! Do I purchase sheet cam through langmuir ?

Well, you’ll save $10 if you do, but you’ll also have one layer of processing on the license, which, by now, they’ve probably got it fairly reliable.

1 Like

If you just received your table, you use firecontrol, not Mach 3. One port is for torch on/off which I think is right side as you are facing it. The other port is THC if you have a pro table. I bet its something simple. I’ve had mine, OG with xl extension, for 4 weeks now, no experience at all. I am having a blast with it. All xmas presents have been hand made with it. I use Inkscape and sheet cam. Way easier then fusion 360. I am still learning but it gets easier as you go. Don’t give up!!!

1 Like

Hang in there…it can be frustrating…but…BUT… you will get it working and people here will help you…

Thank you! The ports on mine are backwards, as I’m looking at the front of the plasma cutter the instructions that came with the cables said to plug the long cable (on/off) to the right port. When I did that I got nothing, unhooked everything, uninstalled everything, re-installed everything, hooked everything back up and nothing. My gut feeling told me to try switching on/off cable to let port and i got it to fire manually.
My issues now is that I’m running a straight line cut and it will start cutting then stop cutting compressor stays on an it proceeding to run the program but stops cutting.

I can set the pierce delay and sometimes it will pierce and sometimes it doesn’t pierce, I’ve tried 2 & 3 second delay.

1 Like

Work clamp should be on the metal being cut, not hooked to the table. You need 100 to 120 PSI of air with a 3/8" hose to the plasma cutter. Torch height should be .060" between the cutting tip and the metal. If your using a cnc shield you need .030" between the shield and metal. Do not use a drag shield.

1 Like

Have to admit that the same thoughts ran through my mind more than once a few months back when I finally got mine. I also ended up with a R45 that the leads were backwards inside the machine.

What turned me around was the forum. I would post my questions and problems including the torch not firing/wiring and in no time at all had a response. I was instructed to go ahead and switch them that no harm would come from trying. Problem SOLVED.

I find myself asking less and less questions these days. This happens be my first reply to someones questions as I feel as though I have enough of a handle on things (basic and simple) to start paying back for all the time and effort other forum users gave to me when I was struggling.


As to compressors… In addition to the required pressure, the two most important considerations are DRY air, and VOLUME of air, (I might add "Dry Air again as it is just that important!) What compressor are you running? What drying devices are you using? may not pertain directly to your current issue, but will CERTAINLY come into play soon.

1 Like

thank you…I was and am the same way still…I have some experiance under my belt…but by participating in the forum…you not only share the experiance…you pay it forward…and Langmuir can also learn from us

Ground clamp? Sorry Just asking.

I have the ground clamp on the material

Ok just to clarify (sorry)

You are using mach3 to control table and plasma is that right?

You mentioned downloading/buying sheetcam…what are you using to generate gcode for your program? ( i know very little about mach3)

You need a code to turn on torch, then a move command with a feed rate. Etc. You also mention using both ports on the plasma…do you have a small square box every thing plugs into? That is thc or torch ht control and I didn’t think regular crossfire used it:thinking:

So without a cam program to convert a cadd type drawing into a program to tell machine what it needs to do may be root cause of issue?