Had enough with this pos

this whole endeavor has been a giant pain in my ass, fusion wont run on 3 computers, firecontrol is slow and only works 1/10th of the time, machine just does what it wants after i click a button and its even worse with the part support sent me. The only thing that works worth a shit is sheetcam and that is useless without firecontrol and im out $140 for that.
yes ive tried EVERY version of EVERY program/download on all computers, ive been jacking with this POS since october and managed, somehow, to cut 4 things…sell it or smash it, im done.

Alot of issues.

Will your machine preform a straight line cut properly
using FireControl? ( Try a cut it 20 or 30 inches Long)

this is your topic from October what have you done since then?

What plasma cutter are you using? (Edit: I see from the last post it is the Razerweld 45)

I’m sure we can get your issues resolved we just need to know where you’re at to begin with.

@toolboy Glen is the guy that made that video and is on here all the time. Maybe he can shed some light as to what he found.

I empathize with you. It has not been candy and roses for me. If you are willing to have the patience you will figure it out with the good people on this website. None of us are here to try and sell the Langmuir System on others.

So you can trust that it is a group of individuals that are are all working out the problems and help people get satisfaction with accomplishing something that not everyone can do.

I have had my system up and running for about one year. I theorized with my wife that only 10% of the world’s population even have the capacity to go through all of the learning that it takes to run one of these systems and of that 10% only about 1% are willing to try. Once you finally start sorting out the issues you will see that you are not that far off from success.

@TinWhisperer has great advice and knowledge about Fusion 360. It is free and if you follow some of his videos he can problem solve. I thought I would learn SheetCam but buckled down and used the CAM feature of Fusion to save on all the program learning. So far I am learning more and more.

@toolboy has great trouble shooting sense of systems and will take you through a check list so to speak.

I guess I should not volunteer people but I am just saying, there are a lot of people that will help and not be judgmental. If you are really just venting and don’t want the system any longer, that is another thing.


I have had my pro for 3 years and no problems with it at all. I don’t have THC on it. It has been flawless. I use sheet Cam for cam, Inkscape for signage, delta Cad and bend-tech software for rock crawler builds. I never used cnc machines or computers until I bought my crossfire pro, I read every post in this forum while waiting for pro to arrive and watched a lot of YouTube on using software. I learn every day using the software, but never been stumped I figure it out.
I grew up in logging family so been stick welding,tig welding, plasma cutting and oxy acetylene welding most my life so have a good grasp on using these tools.
I bought the Xr a few months back and just now getting a few projects cut on it, so far it is awesome table.
You need to go back and recheck things and read instead of crying how big of a piece of shit you think something is because you won’t put effort into figuring something out.


video of what is going on with this brick.
bless the guys in support that are helping with this, they are sending a new board today.
have to put it on 1" step or it will hit the stops.

klattin55 (@klattin55) TikTok | Watch klattin55’s Newest TikTok Videos

I watched the video. I think what you are showing is a delay between pressing a jog direction and the table reacting.

My system does this too. I have to be careful not to press “Continuous” or it slams the hard stops and keeps pushing. Older Dell Latitude w/Win 10. However, I have successfully cut many pieces.

After I load FireControl (FC), the first thing I do is try to jog. If there is a delay, I close and open again. Sometimes I have to close FC three or four times before I get immediate response to a jog command.

Also, early on I tried running cuts when this delay occurred. My real-time display would always freeze while running the program.

Why? I have no idea. I’ve tried several revisions of FC, tried the “Priority” mode loading, etc. For me at this point, “it is what it is” and I just re-load FC until it works.

1 Like

you are correct and this is doing the exact same thing. this problem was noted by another user over 2 years ago and langmuir said they fixed the problem, apparently not.
I could just do what your doing but i want it fixed so i dont have to worry if its going to work today or not.

1 Like

what versions of FC have you tried?

i tried them all but FC says i have to use the compatability version so im using that one…for the umpteenth time seems like…

have you tries 20.5? i’ve never went up from that version since it came out probably about 2 years ago and have been using it ever since. seems like everything from 20.6 on up had issues in one way or another.

might wanna try that version for shits and giggles. it’s not listed on the download site but still on their server.


1 Like

I am currently running 21.1.5 but have tried other versions with the same results: 2-4 second delay between jog request and jog movement; real-time display freezing; FC freezing during cut.

Like I said above, I can reload it until I get instant response from the jog function, and it works fine. If I don’t, bad things happen.

I cant offer any help, but curious what operating system you have? Windows 7? Windows 10?

I have Win 10.

windows 10